-1

I tried to connect to my TP-Link ADSL2+ Modem Router (TD-8951ND) with my Xperia L, it worked fine the first three days, but now when I try to connect it shows "Saved, secured with WPA2" .

I tried almost everything but failed to connect. I tried resetting, restarting, changing password/id, keeping security open, manually adding the network etc.

How can I solve this?

  • Try to connect another android device (I know it is hard, but you have to he sure where the problem is. Maybe a friend of yours can help). Does Ethernet work fine? – Sid Aug 12 '13 at 16:20
  • And are you sure you have good signal strength? I myself experienced this problem once or twice when I was a bit away from the router. – Sid Aug 12 '13 at 16:26
-1

Even i was facing the same problem since day one. FYI but it is connecting to the other wifi network. Finally it worked in this way.. i went to the router setting added Guest network and security none and do apply. once setting are updated turn off ur router for 1 min and switch on. restart your phone. Then try to connect to the Guest network.

Once you are able to connect then you can change the security settings by changing None to WPA in the security.

Hope this helps u .. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.