8

I was trying to root my nexus 4 by the following steps:

  • Download and copy the file UPDATE-SuperSU-v1.43.zip to /sdcard/
  • Download the file CWM 6.0.3.5
  • Got into Fastboot/Bootloader Mode on Nexus 4
  • Execute the command fastboot flash recovery recovery-clockwork-touch-6.0.3.5-mako.img
  • Choose RECOVERY from the Fastboot menu and enter Recovery Mode
  • In ClockworkMod recovery “flash zip from SD card”
  • Then selected “choose zip from sdcard”
  • Now I should see the copied file UPDATE-SuperSU-v1.43.zip but there was none, and I got the output `Can't mount /sdcard/

Then I tried to use Install zip from sideload

  • I sent the file with adb sideload UPDATE-SuperSU-v1.43.zip
  • I get the output:

    Restarting adbd...
    E:Can't mount /cache/recovery/last_install`
    E:failed to open last_install: Invalid argument
    Finding update package...
    Opening update package...
    Installing update...
    ***********
    SuperSU installer ZIP
    ***********
    Mounting /system, /data and rootfs
    Disabling OTA survival
    Removing old files
    Creating space
    Extracting files
    Restoring files
    Setting permissions
    Unmounting /system and /data
    Done
    

Then I go back and choose reboot system now but when booting only the GOOGLE sign pops up and then the X (I was waiting for about an hour)

SOLVED I did a full reset by downloading the original factory image from google here

And then I followed the steps in this tutorial: here

  • I don't know about your method, which seems pretty complicated and you might have done something wrong. But here is the method I've followed and it worked like a charm. – Alex Dumitru Aug 14 '13 at 1:14
  • Trust me my friend, using Wug's Nexus Root Toolkit v2.1.4 is the way to go with ALL nexus devices. Double check your drivers too (toolkit will do this) – AtomicDog Feb 18 '16 at 17:05
  • Put the Solved part in an answer, and copy down relevant details from the links to prevent a link rot. Then after 2 days, accept your own answer. – Wrichik Basu Nov 12 '17 at 5:32

protected by Community Feb 4 '17 at 20:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.