When trying to flash a Galaxy S3 (ATT), I get

ERROR: Failed to detect compatible download-mode device.

below is the log,

$ sudo heimdall flash --RECOVERY recovery.img
Heimdall v1.4.0

Copyright (c) 2010-2013, Benjamin Dobell, Glass Echidna

This software is provided free of charge. Copying and redistribution is

If you appreciate this software and you would like to support future
development please consider donating:

Initialising connection...
Detecting device...
ERROR: Failed to detect compatible download-mode device.

4 Answers 4


Start off by making sure that you're plugged into a USB 2.0 port. Then,

put the device in download-mode,

$ sudo adb reboot download

continue flashing with heimdall,

$ sudo heimdall flash --RECOVERY recovery.img

That should work,

Initialising connection...
Detecting device...
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
PIT file download successful.

Uploading RECOVERY
RECOVERY upload successful

Ending session...
Rebooting device...
Releasing device interface...
Re-attaching kernel driver...
  • 1
    I don't see how the error is related to the answer. Usually when heimdall tells you that there is 'no device in download mode' then it is unable to find a device. This can be caused because the permissions of the device's USB node, which prevent the user running heimdall to access the device node.
    – Flow
    Commented Aug 14, 2013 at 22:32
  • 1
    Oh I just saw the sudo before the heimdall command. Well this would fix the error of course. Maybe you want to point that little fact out in your answer.
    – Flow
    Commented Aug 14, 2013 at 22:35
  • Or using heimdall with a device in download mode and restrictive device node permissions could cause this error. Then sudo will "fix" it.
    – Flow
    Commented Aug 15, 2013 at 7:21
  • 2
    What's wrong with USB 3? I tried everything, then noticed the first sentence!
    – PhilMacKay
    Commented Nov 15, 2014 at 16:18
  • 5
    adb reboot download gives "error: device not found" for me.
    – Geremia
    Commented Apr 3, 2015 at 8:33

Got the same issue years later, and solved it by.. using another USB cable!

Indeed, some USB cables are only made for energy transfer and do not support data transmission

You may also want to test other USB ports and check if your device is detected with lsusb


One possible explanation is that you have confused recovery mode and download mode which are (I have just discovered) two different things on some phones, mine included. I had the same error and switching to download-mode fixed it.


Install Teamwin recovery put in recovery mode wipe everything fix system partition reboot from recovery into download mode now flash worked for me

  • The question was asked in 2013, for this to be a valid answer you're going to have to elaborate. Include bullet point instructions, and screenshots. Commented Feb 24, 2016 at 0:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .