0

I have a Galaxy S2 i9100g with CM10.1 release. Everything is peachy except that the USB port seems to be going -- most of the time I can't charge or connect to a PC.

I'd like to send it in for warranty repairs, but I figure I should put it back to factory before I do so. Normally I'd find a "stock" image and flash it with Odin or something, but I wouldn't trust a firmware update to complete successfully over the wire with this wonky connection.

(Before you ask: this is definitely not a custom firmware problem; it won't even charge properly when turned off, which is before any custom ROM / bootloader even starts.)

Can I somehow flash back to factory via recovery? If so, can I then re-flash back to CM10.1 (in the event I can't get it repaired for some reason), without using the USB connection?

  • 1
    Have you tried another USB cable or the USB port on the PC is dying? This may seem trivial but have you eliminated that first before doing the reverting back to factory state of device? – t0mm13b Aug 14 '13 at 18:59
  • Yup, I tried at least 3 different chargers, plus 2 USB cables on different PCs. It's a consistent problem. It's possible that the port is just "dirty" or something -- I might try cleaning it with an old toothbrush before I send it back -- but it seems more likely to me to be an internal problem. – James B Aug 15 '13 at 19:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.