3

It's been happening for a while now but I've just gotten around to posting this issue. I'm running Cyanogenmod 10.1 on my Galaxy Note 2 but one fine day, it stopped showing me the signal bars. I've even updated my ROM twice but it hasn't resolved the issue.

The phone calls and text messages work just fine but it always shows me that I don't have signal. Here's a screenshot:

Screenshot
Screenshot (click image for larger variant)

Would any of you know why this is happening and how I could resolve this issue? Thank you.

  • Other icons, especially E911, which is present on all phones and cannot be turned off, is also not there. Also, a WiFi icon should be there, if connected. So there's an issue of 3 potential missing icons. Do you have an app which uses notifications that may be blotting the icons out because it is sized incorrectly? – wbogacz Aug 16 '13 at 13:04
  • 1
    Isn't E911 specific to the USA ? – Matthieu Harlé Aug 16 '13 at 13:19
  • OK, so I'm not the NSA - I didn't really look up the OP's home. My comment about obscured icons is still a possibility. – wbogacz Aug 16 '13 at 14:16
  • @wbogacz, it's definitely not an icon issue. If you look at the answer below, the part about the dBm values being skewed is correct. – Mridang Agarwalla Aug 19 '13 at 11:43
  • So How did you solve it?I'd really appreciate it if you answered your question so I won't need to ask it again. – Behrooz Nov 14 '13 at 12:13
1

This is definitely due incompatibilites between the RIL and the baseband/modem firmware. The RIL or the radio-interface layer are the libraries (shared-objects) that allow the phone to talk with the modem firmware. I found this issue on the Cyanogemod JIRA: https://jira.cyanogenmod.org/browse/CYAN-2172 If you read the comments, you'll see that people have solved this issue by flashing a compatible firmware.

Since I'm now running Cyanogenmod 11, I dug around XDA and found a leaked 4.4 firmware for my device. It was packed in a CWM-flashable ZIP so I flashed it and voila.

Please remember to backup your device, your current modem/baseband and the RIL files. Flashing a new RIL isn't necessary always but helps.

0

This is usually because you have very low signal (ie no bars) but are still connected to the network. Does it ever show any signal bars or is it just when you're in certain locations?

Can you provide a screenshot of the Status page (go to Settings > About > Status) which shows the signal strength? This might help to see how much signal you have.

EDIT: Your signal strength values look way off... On my Nexus 4 (and all other Android devices I've owned) these values are more like

-85dbm 14asu

Did you flash a new radio when you went to CyanogenMod? I'd suggest looking for the latest radio available for your device (probably start on XDA) and see if that makes any difference.

  • please have a look at my revised question. This happens always, irrespective of the signal strength. – Mridang Agarwalla Aug 16 '13 at 12:58
  • I haven't updated any radios. One day I simply used the inbuilt updater to update my ROM and this issue cropped up. I have absolutely no idea what radio I'm supposed to look for. :/ Is the radio different from the kernel? – Mridang Agarwalla Aug 16 '13 at 13:23
  • I don't own a Note so I'm not sure which radio you'd need either. I'd suggest posting this question over at XDA as they will know a lot more about the specifics than most of us. I could be wrong with thinking it's a radio issue but it's a start. If you do get a solution over at XDA please remember to post it here as well for future reference. – bmdixon Aug 16 '13 at 14:29
  • 3
    Something is feeding nonsense to that indicator. The numbers displayed are the maximum values for a signed 32-bit int and a unsigned char. I've seen reports of this on the LTE versions of the Galaxy S3, though that bug was supposed to have been squashed back in February. – Compro01 Aug 16 '13 at 16:20
  • @Compro01, is there anything I can do about this? I'm not sure if Android has a safe mode but I guess that could be one solution. I've even tried wiping my Dalvik and Cache but that didn't help. Thank you. – Mridang Agarwalla Aug 19 '13 at 11:42
0

Its the data option you need to dial ##data# and Touch edit then enter your 6 digit msl codeyou get from your carrier. Then touch More then touch HDR/1X selection. From there you chose your preferred method it Probably was on evdo only but check CDMA or CDMA LTE if you get 4g. Now you touch back button til you asked to recycle phone after that you should see signal bar once restarted. Hope this helps.

0

New here, but here is the, on st least my systems answer. Under Settings, System UI Tuner, Status Bar, CELLULAR DATA must be on (slid to right). You can see the result immediately in Status Bar as you slide on/off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.