2

Nexus One, cleared internal user storage to near-factory settings using the boot menu. My computer is connected to wifi, and I have a USB tether to my phone.

But when I click on "Connect to wifi" -- even in the virgin "user setup" menu -- No networks are found, and the device becomes unbearably slow.

The device had functioned properly for 1.5 years ... until yesterday.

I don't know whether the problem is hardware or software. If it is in software, I would like to fix it... but I don't have wifi, and I don't have 3G.

What are the steps to diagnose this problem?

If it is a software problem, what are the steps to fix it?

2 Answers 2

1

From my experience working on Service Centers I would say it's probably HW. But you can try some things to confirm it or not:

  • Usually Wi-Fi and Bluetooth are on the same SoC. If BT is also not working it's a good indicative that it's HW issue on that SoC.
  • If you go to Settings -> System -> Advanced -> Reset Options -> there is an option "Reset Wi-Fi, mobile and Bluetooth". Have you tried that?
  • Another option is to take a look at kernel logs, even if you don't understand much. With USB debugging enabled, try to connect to wifi and while the device is slow type "adb shell dmesg". If you get a "permission denied" error try "adb bugreport" and in the generated text file look into the "Kernel log" part. If you see consecutive error/fail messages of somthing related to Wlan or Wifi, this probably means it's a HW issue.
0
  1. Tap the Menu button on your handset.
  2. Tap Settings.
  3. Tap Wireless and Networks.
  4. Tap Wi-Fi settings.
  5. Tap the Menu button again.
  6. Tap Advanced ( Figure B ).
  7. Tap the Proxy setting and make sure your Android device is not set up for a Proxy. (Unless the Wi-Fi network you are on requires a Proxy, this setting will get in the way of your device's access to the computer) If you tap on Proxy and see an IP address or domain, delete it.
2
  • 6. Tap Advanced : "The Application "IP Address settings" is not responding [Close / Wait] Aug 17, 2013 at 8:47
  • After rebooting, I tried accessing this menu again, and there were no proxy settings, just settings for MAC address, IP address, and static IP address. The MAC and IP address fields are set to "Cannot use", and the static IP is not in use. In order to use these settings, wifi must be turned on... but as soon as I turn wifi on, the device becomes too slow to access this menu. I'll try it once, then I will have to reboot to speed up the device again. Aug 17, 2013 at 8:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .