1

I know the battery is still being charged because 1) when I power off the phone while the phone is plugged into a USB connector the screen shows the battery symbol with a lightning bolt and then a battery with a animated fill. 2) When I power on the phone the battery charge status screen now displays an expected and much higher value than before the phone was rebooted.

The indicator is now not showing that it's plugged in when I've tried three different chargers and cables which worked just fine in the last few days. The battery percentage slowly drops even though it's still plugged into the USB cable.

This started happening shortly after I installed the Lock Screen app. It has since been uninstalled but the problem persists. I don't quite see how it could've mucked up the settings but the author does have a related Battery Saver app so I suppose there could be some code in there. I tried installing the Battery Saver app which didn't make a difference. I've uninstalled it. I've emailed the author but haven't heard back from them yet.

Added later: Further testing shows that after I power cycle the smart phone the USB connection is recognized once per connection cycle. That is the AC USB cord works once indicating that the device is being charged via the AC. And once the AC USB cord is pulled and plugged back in it no longer changes the status. The same thing happens with a USB cable connected to my laptpo for data interchange.

However this doesn't always work. Just most of the time.

1
  • Did you try a different battery? Is this one the factory one? It may be faulty and possibly not charging reliably.

  • If worst comes to worst, you can try reflashing your GNexus with the default google 4.3 yakju images (after backing up all your data of course) to see if the problem goes away. If it does not then the battery needs to be replaced.

Here is a link: https://developers.google.com/android/nexus/images#yakju and information on how to do it: tutorial You will need to have fastboot and adb installed. There is a way to flash the images without erasing the userdata/sdcard partition if you don't want to backup. (it involves editing the flashall.sh to remove the -w option before running it)

  • I purchased this smartphone used so I don't know if it's the original battery. It does say Samsung on the battery but that sure could be counterfeit. But to me the symptoms don't add up to a faulty battery. It does charge even though the indicator doesn't state it's charging. I'm starting to think there's some kind of service/daemon that's exiting after you unplug a USB cable the first time after you power on the phone. – Tony Toews Aug 20 '13 at 4:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.