0

I have a problem related to connectivity between my desktop (Windows) and tablet (Android 4.1). I bought a new device (Colorovo City Tab Vision 7) and now I want to use it for testing of my applications, because emulation of android is very slow on my computer, although I forced it to create snapshot every run. I have downloaded SDK with Google drivers and also some unofficial drivers I found on web.

When I connect my device, it first appears 'Other device' (label is CTVision7) and it's marked as unknown. I tried to install drivers (Google) for it, but windows said that they aren't suitable for my device, as it's not able to find them in specified directory. After these attempts I tried unofficial drivers. Their installation worked and now my device appears as Android phone, what seems to be good.

But when I run adb devices or launch application in eclipse, there's no available device.

I have turned USB debugging on, so it should work.

Am I missing some step to make my device available for debugging, or are my drivers wrong? Is there any way to get drivers which surely work?

6
  • I'd suggest to give Koushik's Universal Android USB Driver a try. Works for many devices.
    – Izzy
    Aug 18, 2013 at 18:05
  • I tried with same result. Driver is successfuly installed, but adb doesn't see my device.
    – user35443
    Aug 18, 2013 at 18:58
  • Do you get the notification on the tablet to say that USB debugging is connected?
    – Dan Hulme
    Aug 18, 2013 at 20:26
  • Yes, I do. I also tried to connect Samsung Galaxy Tab (which uses different connector) and it worked with Koushik's drivers. Can I get older version of adb and whole SDK somewhere?
    – user35443
    Aug 19, 2013 at 5:22
  • which adb version are you using right now ? Try adb version 1.0.31.
    – Rilwan
    Aug 21, 2013 at 13:34

1 Answer 1

0

Try this universal ADB driver.

1
  • Hi, just FYI, since Google+ is not available anymore, the file cannot be downloaded anymore. It'll be appreciated if you could find another source and fix it. Thanks.
    – Andrew T.
    Dec 6, 2021 at 4:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .