The Google Maps on my Android phone got updated and now everything's screwed up. It keeps automatically zooming way out. It does this whenever the phone changes orientation or when the screen is locked. How do I keep it from automatically zooming out?

The version is 7.1.0 (#701000802).

Here's an example. It automatically goes to the second image after a few seconds, I think because I move the phone.

zoomed in zoomed out

Click the images for larger variant

May I know the reason why it happens? Maybe it's not a problem with Google Maps but my device.


1 Answer 1


The app does this because you're not in navigation mode, you're browsing the route. It zooms out to fit the entire route on your screen when you reorient the device. If you don't want it to zoom, press the navigation button in the lower right corner and optionally switch off voice navigation.

  • How do you get back into navigation mode? I don't see it in the settings menu.
    – Celeritas
    Aug 25, 2013 at 5:08
  • This answer is partially correct. Take note that Maps doesn't provide navigation mode with public transportation anymore (as shown with 'train' icon on the screenshot). Also, pressing the auto-orientation button doesn't prevent zooming out when the device orientation changes.
    – Andrew T.
    Feb 28, 2015 at 4:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .