3

For at least 3 years now, my Samsung Galaxy Tab 2.0 running Jelly Bean is running into some problems. Ever since I hit ~300 MB left, every app I try to download from my device or the web version of Google Play has shown the error 'insufficient storage space availible'. I have tried the following so far:

  1. Clearing Google Play cache
  2. Clearing Google Play data
  3. Removing Google Play updates
  4. Uninstalling some apps
  5. Clearing device cache
  6. Memory Booster app

Any app seems to do this unless I have about 8x the required amount of storage left. By the way, I can't root my tablet.

(and yes, I know this has been asked before.)

Thanks!

EDIT: I now have 360 MB remaining, and I am now trying to download a 15 MB app. After trying to download with no Google play data, cache, and with Google play 1.0, something must be wrong.(Edit- No, duh.)

NOTE TO MOREAKI: unfortunately, no. I do not have a rooted tablet. Memory booster seems to work downloading other apps, but most apps will not download.

Please comment if you oppose anything I have said.

Sometime I will try to root my Galaxy tab to see if that solves the problem.

Edit again: I never did.

  • 1
    I've just added the insufficient-memory tag to your question. You might want to check its tag-wiki for first aid. Basically, the "insufficient-memory" error is triggered once available memory drops below ~25 MB, to give you a guideline. – Izzy Aug 19 '13 at 16:30
  • Do you have a rooted phone and did you install software that fiddles with dex/odex/dalvik-cache like for example Lucky Patcher? If so, in case of Lucky Patcher, you have to tap Toolbox and Remove fixes and backups (insufficient storage available). I had a similar case just the other day, where I had about 3GB free storage and no matter what, I couldn't install any apps anymore. This solved the problem. – Moreaki Aug 21 '13 at 19:58
2

Maybe this will help with your problem, give it a try.

If you root your device, then you can do the following to get more free space to install more apps. For me on my phone, I can free up to 500mb by doing this.(sgs2 i9100)

  1. Install DiskUsage
  2. Run DiskUsage and choose [Root required] -> "/Data"... Then you will see how much storage "/data/data" and "/data/dalvik-cache" uses. As far as I know you can delete the content of them both and reboot without having any problems or losing anything other then temp files. I have done this several times.
  3. To delete the content of any file inside /Data, you will need a root file explorer, not all of them out there works. I am using "CyanogenMod File Manager", but that's not on Google Play.

Hope this helps.

2

None of the answers on this site for the myriad version of this question seem to address the root problem. I've rooted my phone, moved files to the SD card, emptied my cache till my fingers were numb... But because I missed one blindingly obvious detail all my efforts created at best a very temporary fix. When you get the insufficient space message you can then look at the phone storage (or get there from the Settings/Storage option).
The memory is shown in several sections; the first being the Device Memory, then a section for USB and Then the SD Card if there is one. The one you need to look at is the Device memory. Mine showed: Total space 1.97GB, Applications 0.98 MB and Available 225MB. My 'O' Level maths should have made me ask... where is the remaining 774MB?

The answer seems to be in some Android log files that the operating system fails to 'mention'. I found the answer at the following link:

http://www.samsungsfour.com/tutorials/play-store-error-there-insufficient-space-on-the-device-how-to-solve-fix-on-samsung-galaxy-smartphones-all-models.html

The summary is to go to the phone's dial keypad and enter: *#9900# and a screen will be displayed containing, as the second item, "Delete dumpstate/logcat". Click it, close the screen and go and look at your storage again. As if by magic I then had 0.91GB and my play store updates started working again.

Thanks to samsungsfour.com.

  • Sounds like it would work... But I'm on a tablet. How do I get to a keypad? – lucs100 Sep 27 '15 at 14:10
  • +1000 Thank you so much! I was searching and tapping around for hours, and almost convinced to do a factory reste - just found your answer - voila, it works again! Shame on SAMSUNG for such a ridiculous bug in their android version. – maxi.weller Oct 30 '15 at 22:31
  • Repost. How would I do this? I'm on a tablet. – lucs100 Apr 22 '16 at 1:23
1

This appears to be a Jelly Bean bug with Samsung. I've had the same problems on a Galaxy S2, Galaxy S3, and a Galaxy Note 2, all running different (but Samsung based) custom JB ROMs. Even after clearing out all pics and videos, and uninstalling all apps I was still getting 'out-of-memory.' The problem seems to start after the device gets a bit full for the first time.

Only one thing that has worked for me every time: reinstall the ROM (no data wipe necessary). Since you do not have a custom ROM installed I would suggest you try a factory reset and see if that resolves it.

Hope that helps.

  • Hey aggregate, I don't have a custom ROM installed. I also have many apps (and Candy Crush data- please don't judge me) that I would not be happy to lose in a factory reset. Is there a way to back up my device, wipe it, and then move the backup back to the device, and if it is possible, would it work? – lucs100 Nov 16 '14 at 14:08
  • @lucs100 - Hi, I have not seen any effective ways of doing this without a rooted device (you can root almost all Samsung devices easily without having to install a custom rom or wipe the device). If your device is rooted, try Titanium Backup. I've used it for nearly 3 years with no issues whatsoever. I eventually even bought the pro version. – aggregate1166877 Nov 17 '14 at 16:50
1

If you have tried other methods with no success, you can try rebooting your device into Android System Recovery mode and using the "wipe cache partition" option.

Instructions for a Samsung device are below. Other manufacturers devices will be similar but some have different keys to get into recovery mode.

  1. Turn off your phone (Make sure it is completely off. If possible take out the battery then place it back in)
  2. With the handset turned off, press and hold the Volume Up key.
  3. While holding down the Volume Up key, press and hold the Home key.
  4. With both the Volume Up key and the Home key held down, press and hold the Power key.
  5. Release all three keys when the Samsung logo appears.
  6. Press the Volume Down key to scroll to wipe cache partition.
  7. With wipe cache partition highlighted, press the Power key.
  8. Once the Cache wipe is complete, press the Power key to select reboot system now.

The Cache wipe is now complete. The handset will restart.

  • OK, I just read on Android Central that the Wipe Cache Partition does not affect data... I have an app that clears app caches but I'll try this now! Here goes nothing! – lucs100 Nov 16 '14 at 14:22
  • I'm pretty sure this worked, I was able to download and install a new app no problem, except for three things... 1. My device does not have a Home Key, as there are instead three virtual Home, Back, and Task (whatever the two squares indicate) but I got around this, 2. When I pressed wipe cache partition, I got a "dead robot" error but it booted, and 3. When I signed into Google Play Games with my new app, a dialog box popped up and said my device does not support Google Play Services. – lucs100 Nov 16 '14 at 14:41
  • I did try this, and it did work, but now I try this, couple it with a cache wipe from App Cache Cleaner, and it leaves me with 600 mb +. Still I get the error. I've never really thought about rooting, and I'm kind of scared of losing all my data, like with a botched jailbreak on an iOS device, so does anyone have any other fixes? – lucs100 Apr 11 '15 at 13:25
  • I've tried this now a few times and it doesn't seem to work anymore... I'm not sure what's wrong. – lucs100 Jun 8 '15 at 0:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.