I follow the official Android guide here but I cannot start the emulated device. It keeps saying PANIC Cannot start device... as below screenshot.

Do you have the same problem and any work around for me?

Creating the device

enter image description here

enter image description here

enter image description here

Starting the device

enter image description here

enter image description here

PANIC/failed result

enter image description here

  • In what OS are you developing? Windows? – AitorTheRed Aug 22 '13 at 8:31
  • Did you change the RAM from 1024 to 768 as indicated? I used to get this error message, and after I started to make this change for any AVD in my Windows 7 I never seen the message anymore. – Francisco Alvarado Aug 22 '13 at 19:57
  • @FranciscoAlvarado Nope I didn't change that. We have the solution as below. – Nam G VU Aug 23 '13 at 2:28
up vote 3 down vote accepted

Try these steps

  1. Create a environment variable called: ANDROID_SDK_HOME and set it to C:\Users\<<Administrator>>
  2. Open Eclipse > Window > Preferences, click in Run/Debug and String Substitution. Add a new variable called user.home and set it to C:\Users\<<Administrator>>
  3. Create an AVD and run it.

Note The <<Administrator>> means the name of your Windows account; it is where resides the folder which contains your .android directory

An android project member says here:

As a work-around, you can define the environment variable ANDROID_SDK_HOME to point to the directory containing your .android directory. The emulator and SDK Manager will pick it up properly.

Also you should check that the AVD is created in the location D:\NN\.android\avd (check in your screenshoots, just above the list of AVD, the path in List of existin Android Virtual Devices).

  • My PC doesn't exist the path C:\Users\Administrator in step 1. Does that mean any user who has administrator access right? – Nam G VU Aug 22 '13 at 9:20
  • I have update it myself indeed. Thanks – Nam G VU Aug 22 '13 at 9:28

Uncheck scale display to real size, It will work for you, Or try to lower the Screen size column.

  • Tried it and that not works – Nam G VU Aug 22 '13 at 10:59

I faced the same problem, which nearly drove me crazy. System: Win7 64Bit, Eclipse/ADK 64 Bit, JRE7 64 Bit - latter copied from C:Programs\Java\ as "jre" under the Eclipse folder... (finally Eclipse started). How I solved the lacking start of the Emulator with an android virtual device:

  1. Look under C:Users\YourUserName\ .android if you can find there a folder named \avd containing subfolders named after the android virtual devices you created. If that is not the case (as it was on my machine) then you probably have moved long ago your account's user data via a symbolic link to some different location, as it was the case in my system. Eclipse (the virtual device manager of the ADK) will create the virtual devices there, but will search for them in the Windows default C:Users\YourUserName\ .android path.

  2. Locate the real folder with your user data, in my case it was: D:\Win\Users\YourUserName where I finally found the AVD-folders needed for Eclipse: D:\Win\Users\YourUserName\ .android\avd...(2 Subfolders with the avd's)

  3. Just copy the avd-folder (in my Example) D:\Win\Users\YourUserName\ .android\avd to the "usual" Location, where Eclipse looks for it, to C:\Users\YourUserName\ .android

This enabled me to : Start the virtual device and to load the Hello World example from Eclipse into it.

What did not help: Create an environment variable named ANDROID_SDK_HOME with the value D:\Win\YourUserName\ .android and add it to the environment variable paths list: path= ....;%ANDROID_SDK_HOME%;....

Eclipse does not seem to search for such environment variables, but obviously rather relies on the presence of all of the files in the Windows default locations of the user's personal data.

cheers

There are 2 things that you can do to get it over with.

  1. Copy /root/.android/avd content to $HOME/.android/avd. Just a matter of simple command and worked for me. :D

  2. Before android search .ini files in $HOME/.android/avd it looks for environmental variables called $ANDROID_AVD_HOME. SO you can set its value to root/.android/avd. :) (y)

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.