When I go to Android Device Manager, my tablet is listed, but not my phone. I had signed up just as soon as ADM was available, and at that time both devices were listed. Now, for the last several days, I can only see my tablet. (For what it's worth, both devices appear in the "My Devices" section of the Google Play Store.)

I have done the following while troubleshooting:

  • Ensured that the Android Device Manager settings in Google Settings are both on. I have even toggled them off and back on again
  • Ensured that Location Services are on
  • Ensured that all sync services for my account are toggled on and work
  • Have connected to the Play Store several different times
  • Ensured Google Play Services is at the latest version
  • Made sure I'm using the right account. (In fact, I removed the other secondary accounts from the phone)
  • Power-cycled the phone several different times

I could understand if ADM couldn't find the phone due to it being off, out of range, poor signal, etc., but ADM would at least display the phone and tell me it couldn't find it.

So, any suggestions to get my phone to show up on Android Device Manager?

I would like this to be working before something happens to the phone. (Murphy's Law and all that.)

Although it shouldn't make any difference:

  • Tablet: Nexus 7 (2012) with Android 4.3
  • Phone: Verizon Galaxy Nexus with Android 4.2.2

Addendum:

There's apparently some (relatively new) advice on the Android Device Manager help page:

  1. Open Google Settings from your device's apps menu.
  2. Touch Android Device Manager.
  3. Uncheck Allow remote factory reset.
  4. Go to your device's main Settings menu, then touch Apps > All > Google Play services.
  5. Touch Clear Data. Note that this action doesn't remove personal data.
  6. Go back to Google Settings and select Allow remote factory reset.
  7. Restart your device.

I have followed these steps, but it doesn't appear to have worked.

  • Silly question @AlEverett but both devices have Android Device Manager installed? Have you clicked on refresh on the box on the webpage itself where it shows the devices in dropdown box? Maybe you need to activate the wifi to internet on the phone for a while to let the system "sync up"? Yeah, that's more than one silly question - sorry Al! :) FWIW Google servers are playing silly as well with me, gmail not proper updating inbox emails, google play on android unable to connect at times... – t0mm13b Aug 22 '13 at 13:28
  • Yes, it's on both devices. (It's part of Google Play services.) It used to work. Yes, I've refreshed the webpage. This has been going on for a few days and I've checked the site multiple times from multiple locations and different browsers. – ale Aug 22 '13 at 13:30
  • 3
    That seems to be a common issue. None of my devices show up there. Searching on the web reveals many people have this issue, but I saw no remedy yet. Looks like one more of those incomplete services (like Google Cloud backup, which backs up, but only sometimes restores, sometimes not, sometimes partly, but never deletes). Launched too early, before completion. – Izzy Aug 22 '13 at 15:01
  • Thank you sooo much !! you finally helped me to see my device Thank youuuu !!! – Chris Sim Oct 30 '14 at 8:52
up vote 21 down vote accepted

Well, I don't seem to have an answer why this was happening, but I got some advice about how to finally fix it.

From Ryan Lestage on Google+:

  1. Clear data for the following apps:

    • Play Store
    • Download Manager
    • Google Services Framework
  2. Restart your phone.

  3. Fire up the Play Store app.
  4. Wait for the device to show again on the web Play Store. It will appear under Settings > Devices. It may take a half-hour to several hours to appear.

When your phone has shown up in the Play Store with the date registered as today's date, proceed with the next steps, but not before.

  1. Open Google Settings from your device's apps menu.
  2. Touch Android Device Manager.
  3. Uncheck Allow remote factory reset.
  4. Go to your device's main Settings menu, then touch Apps > All > Google Play services.
  5. Touch Clear Data. Note that this action doesn't remove personal data.
  6. Go back to Google Settings and select Allow remote factory reset.
  7. Restart your device.

I would like to know exactly which of these steps was the magic sauce, but I'm content that it worked at all. I suppose that Play Store connection makes some sense, because while my phone was listed there, it showed a "Last Used" date back in March or somesuch.

I really hope that the setting sticks this time, and that I won't be forced to repeat this process every couple of months just to protect my device. (If so, I'll go back to some of my other options, like Carbonite and/or Lookout.)

  • Huh? That is convoluted way of dealing with it, but guess @Izzy is on the ball here, the whole thing was a bit rushed out the door to be honest... maybe for KLP readiness... no idea. Time will tell. :) – t0mm13b Aug 22 '13 at 18:49
  • Thanks, this fixed the issue for me as well. Small caveat: after the data was cleared (I suppose it must been Google Services Framework specifically) and restarting I was unable to log into the Play Store app for about 30 minutes. It resolved itself though. – Sundae Apr 11 '15 at 9:19
  • At step 3, Fire up the Play Store app, I got "Google sync error" and the only way to recover was to factory reset my phone (Android 4.4.4, Cyanogenmod). And still no luck with ADM. – Radu C Jul 21 '15 at 19:14
  • 2
    Thanks, that resolved this very frustrating problem. Hard to believe it would be this much of a hassle. One note I want to add: Maybe things have changed since two years ago, but there is no "Android Device Manager" in Google Settings as indicated in steps 1 and 2 in the second list. Instead, I went to the device's Settings, and from there Security > Device administrators > Android Device Manager, and unchecked Allow Anodroid Device Manager to lock or erase a lost device (and re-enabled this setting in step 6). – Adi Inbar Aug 1 '15 at 4:27
  • Worked for me after a painstaking batch of attempts... i still use Android 2.3, and removed Google Play Services (because it consumes a lot of space and resources), and ALL worked fine for YEARS, until last week, when i start getting PLAY STORE download errors, and lost the device on the Play Store / Device Manager. HAD to install Device Manager App (never used until the present day) and follow all these steps. Problem solved... (google changed something??) – marcolopes May 14 '16 at 8:19

I don't know if this will help but I had 2 similar problems:

HTC One Phone: I had to go to the "play store" and download the app for the Device Manager even though it was supposedly installed. I could then surf the web and go to the google.com/android/devicemanager website using my cell phone and I tested the ring and it worked.

However, when I went to my computer I ran into the same error message as noted in the comments above that I had no device connected. So, I left my HTC One plugged in overnight and some applications ran that cleaned up the temporary files and fixed a few other things. When I logged back onto google.com/android/devicemanager the HTC One showed up on the website on the top left hand corner.

So, I guess you have to have the latest Device Manager App for your phone and clean up all the temporary files on your PC and have your device plugged in so that it can be recognized.

protected by Community Feb 3 '15 at 4:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.