1

I am switching from iPhone to Android. I do not speak Android/PC. I speak Apple. This has been a difficult transition, and I require a simple explanation (pretend I am 5 years old).

My new Alcatel One Touch 979 did not have Android Market / Google Play installed. After much searching, I figured out how to get the application. I downloaded it - safely - and it was a very slow start, but now it only crashes. I tried three different platforms, each having the same outcome:

  • Android Market 2.3.6.apk
  • Google Play Store 3.5.16.apk and 3.8.16.apk

The error message reads "Sorry! The application Google Play Store (process com.android.vending) has stopped unexpectedly. Please try again." My only option is to force close.

The phone is listed as a supported device on the Google Play help page. I suspect I'm accessing an incompatible version, but I just don't know - and there are so many versions from which to choose.

When I log into my Google account via the laptop, I see my phone's application activity! I have a lengthy Orders list, but nothing has downloaded to the phone. To that end, when I review the "Device Manager" option in my account, nothing is listed, but when browsing the Play store and selecting applications, the compatibility indicator recognizes the phone and states whether the app is a match. How and what is happening?! The user manual for the phone is in a foreign language (Mandarin) with no English translation, so I cannot use it to troubleshoot. Here is some information about the phone:

The phone has Kernel version 2.6.35.7+SW2SVR@Android-Server #1. The Baseband version is BCM2155x_CustomerRel_SS_1_3_9_P3. I have no idea what any of this means, but I'm sharing in case it matters. The micro SD is a 4GB memory and the internal memory is 126MB.

I have tried clearing the data and the cache. I have also tried a hard re-set, which reverts the phone back to its linguistic Beijing origins, and I needed assistance getting it to English language. I am out of ideas, except to wait for the iPhone 5S launch. I've only had the phone for 15 hours; I'm an Android infant newborn. My head is spinning, really. There must be a kinder, simpler way to use the application store on this phone.

Thanks in advance for your suggestions!

  • If the phone didn't come with Google Play, it may be that it doesn't support it. Google Play doesn't operate in China anyway, so perhaps it can't work on the Chinese version of the phone. If this is so, you might be able to make it work by replacing the operating system on the phone with the correct one for your country, but (a) that's quite an involved process, and (b) it might not even be possible - sometimes the Chinese variant of a phone has completely different hardware (so it can be cheaper). – Dan Hulme Aug 23 '13 at 8:36
  • @DanHulme ^^ Thanks for your suggestion. According to Google Play this phone is a supported device: support.google.com/googleplay/answer/1727131?hl=en#T. It is confusing because it's on the list but came without the application. However, it doesn't say which version of Google Play is suitable for the phone, so I presume the most recent should be OK. So very confusing! When you say "replacing the OS" does that mean "root"? Please clarify :) – user39921 Aug 24 '13 at 2:28
  • My point is that although the phone itself is supported, the Chinese version might not be: it might be missing other things besides the Google Play apps themselves. But you should definitely try onik's suggestion first. – Dan Hulme Aug 24 '13 at 5:28
2

You can't just install the APK, you have to download a GApps package, which contains all the Google applications that come with Google licensed phones. This, however, requires rooting the phone and installing a recovery.

The reason for all the trouble is that while Android is open source, Google Apps are proprietary code, and devices have to be licensed with Google in order for the Apps to be included on the device.

For more information, see How can I install the Google Apps Package (Play Store, ...) on my Android device?, RootzWiki GApps page and GApps download.

  • OK! Your explanation is understandable to me. I viewed the GApps website - or 1 of them - and it was a lengthy list. I don't know which to use. Also, how is it the Google Play on my computer sees the phone - sometimes - but the phone doesn't see the application? Do I need to log out of Google before installing? Also, will rooting the phone make it go back to Mandarin? I saw a pay-to-use rooting website. What is trustworthy...? I'm not worried about wiping the phone as long as it will function properly. Many thanks :) – user39921 Aug 23 '13 at 8:45
  • Rooting shouldn't revert the language, but if you have to wipe the device then yes. Unfortunately, Alcatel phones aren't generally well supported when it comes to rooting/flashing/recovery, and I can't find any guides for your model, so I can't be of assistance any further. – onik Aug 23 '13 at 9:01
  • @user39921 First, install the drivers for your device. If you don't know how to do that, try using the PDANet installer to get them. Then, install ADB and use the command adb flash PACKAGE_LOCATION to install gapps. After that, you should be fine. Make sure your bootloader is unlocked before you do this. Otherwise you may have issues. – Dillmo Aug 23 '13 at 11:16
  • ^^ Hello! OK, are you saying that before I root the phone, I need to install drivers, or are you saying to NOT root the phone and install drivers? Also, what is a bootloader? Thanks! – user39921 Aug 23 '13 at 16:35
  • @ONIK - If you are literate in Mandarin, I can scan the manual for you. Thanks for your help. I'll try and post an update later today. – user39921 Aug 23 '13 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.