1

How to i install binaries on my non-rooted tablet i have the terminal application called Terminal IDE and i followed the instructions, i put my compiled binary in the folder local/bin/. I comiled a C program using the appliaction called C4droid and then I exported the binary to the /local/bin/ folder but when i tried to run the program it said permission denied.

what am i doing wrong? How do install binaries?

This is the program that I am trying to install http://sourceforge.net/projects/base64/

1 Answer 1

2

So what 'Access Denied' in this case is you do not have the correct permissions to execute the file. This can be solved 2 different ways:

  1. use the sudo command (super user can run any file)

    sudo myprogram -options param1 param2 param...

  2. use chmod o+x filename to let anyone execute the file

so basically you need a rooted device to be able to run that file, unless you change the permissions of the file before you transfer it to the device. You can use the chmod command to add the execute permission to the file before you hand it off to the device. This way anyone can execute the file. Be warned, adding the execute permission for everyone is a security hole if the program can be used to change the file system in any way. Rooting your tablet in this case might actually be safer.

5
  • 2
    There is no sudo command
    – kyle k
    Commented Aug 26, 2013 at 3:33
  • you need to root your tablet to get permission to use the sudo command.
    – John
    Commented Aug 26, 2013 at 3:36
  • But when i changed the permission of the file it ran just fine, the program is for encoding/decoding binary files in base64 so that i can easily send them using email.
    – kyle k
    Commented Aug 26, 2013 at 3:36
  • 1
    ok great, I'm glad you got it running!
    – John
    Commented Aug 26, 2013 at 3:36
  • 1
    @John There is no sudo command on Android (common mistake for us Linuxers), one simply calls su here. However, chmod is the correct way here, nothing to do with su. What you most likely wanted instead, was sh myprog param param – the trick used to execute shell scripts even if they're located on an SDCard mounted with noexec ;)
    – Izzy
    Commented Aug 26, 2013 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .