I have been having this issue between ROMs, as well as between connections. I am currently running ParanoidAndroid 3.94 (Android 4.3) with franco.kernel 3.0.89. Other apps consistently update fine. The error I get is

Update for "application-name" could not be downloaded due to an error. (403)

I have eliminated the following factors:

  • Network issues (issue persists with two separate Wi-Fi points, as well as mobile data)
  • Google Play cache issues (I have cleared cache and restarted the Play app)

If I "sacrifice" one of the apps that do not work and uninstall "TuneIn Radio Pro" from Play store — I am then also locked out of actually getting the app back on my phone. The button in the Play store says "Install" (note: not "Purchase", so my existing ownership is recognized), I click it and "Accept", and the app even starts downloading! However, after the installation starts, I get the following error message:

Error: Package file is invalid

Now, I am able to get all of these apps just fine on another device I have (Nexus 7), so I appreciate the fact that there is something up with my phone that causes this. However, I am not certain that it has to be something with the phone as it can also be something on Google's end not handling my dual accounts very well and therefore throwing the 403 (Forbidden) error when I try to download an app I actually own.

2 Answers 2


This was solved by going into /data/data/ and finding the appropriate folder belonging to the failing app. I found one with "swiftkey" in the name, deleted it, and following that the update worked just fine. Most likely, the app installation was failing in the background with INSTALL_FAILED_UID_CHANGED due to the app being restored with TitaniumBackup, as detailed in this answer.

So, in short, this seems to be an error caused by the UID changing between installs and Google Play throwing a fit, and it's solved by making sure app data is removed.


Delete the Application from your Device

You are installed the same application in your device, after that you are trying to install the same application from Android market

  • Please delete the pre-installed application from your device, then try to download from playstore, it will work 100%

  • Alternate scenario is: Please change the package name of the application, Your application will work fine.

  • Firstly, the app was not "pre-installed" (although I installed it with TB). Secondly, just removing (uninstalling) the app did not solve the issue, you need to use a file explorer to remove the corresponding folder in /data/data.
    – pzkpfw
    Aug 26, 2013 at 13:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .