Trying to set up my shiney new Nexus 7 (2013 edition) I used MTP to transfer files (music and ebooks) to the device from my Win7 PC. It seemed to work, but then when I ejected/disconnected the tablet, it registers that there is space being used in the folders, but doesn't show any of the files (when looking at Storage it says there's 600MB worth of stuff in the folder, but when I tab on it there's no files listed, and my music player and e-reader apps don't see anything either).

What gives?

Thanks in advance for your help!

  • Have you looked with a file manager? Which directories have you transferred the files to?
    – Izzy
    Commented Aug 26, 2013 at 18:02
  • I have only looked using the 'storage' menu and Windows...I put the files in the 'Music' and 'Downloads' folders that are in there by default.
    – Artiloop
    Commented Sep 5, 2013 at 17:38
  • So maybe you can try with a file manager and let us know? Some file managers also contain a search feature, so you could have them look specifically for one of the files transferred.
    – Izzy
    Commented Sep 5, 2013 at 18:35
  • I installed OI File Manager, and it could see everything. When I copy-pasted things around using that, they showed up in Kindle and Kingston. Weird, but I guess that solves this?
    – Artiloop
    Commented Sep 8, 2013 at 15:03
  • It's up to you to say whether the issue is solved :) Feel free to answer your own question, and later accept the answer to show it's a solution. Please include the steps taken so we are able to follow/reproduce what was going on :) Thanks!
    – Izzy
    Commented Sep 8, 2013 at 18:42

2 Answers 2


At Izzy's suggestion, I installed a file manager (OI), and was able to see the files that my Android itself didn't recognize. I used OI to cut-paste them to a new dummy directory and then back to where they belonged, Android recognized them and I can use with the relevant apps (Kindle, Kingsoft Office).


For those of us who are frustrated in trying to alter the file system to MTP and cannot find how to change it. Do not despair.

If you've opened Samsung Kies and connected phone with a USB cable and got the error message, go to your phone and swipe top to bottom on the NOTIFICATIONS list you will see the USB symbol on the left hand side and the line stating - Connected as Camera. If it says - Connected Media Device - then your connected properly. To Change from Connected as Camera, tap/select the line - Connected as Camera and you will be shown another screen with the Camera option selected - Just select Media Device MTP and you will be able to connect to Samsung Kies, and all will be calm and peaceful, no more screaming at the PC or mobile phone.

  • Welcome to the site. In this case, the questioner already said he was connected with MTP, so your instructions for switching from PTP to MTP aren't relevant.
    – Dan Hulme
    Commented Aug 1, 2014 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .