1

I have a galaxy S 3(d2att,US variant). Today I got an update for Google Maps.
But when I try to update it after downloading play store gives error as "Application requires newer SDK version".
I'm running on 4.2.2 Jellybean. Phone is rooted and using CynogenMod 10.1.2.

How can I update it? or Why it shows so?

Screenshot
Screenshot (click for larger variant)

1

Google Maps needs the correct version of gapps to work. Download the gapps and install it from recovery

  • From what I know, maps is not included – Mihai Sep 10 '13 at 6:35
  • But gapps has other google apps, play store etc built in, maps needs the version of gapps to match what is on your phone to work. It's a conflict. Give it a go and see how it works out! – RossC Sep 11 '13 at 12:14
  • I have the latest Gapps installed..but I can't update. Always giving this error. – Akhil Sep 13 '13 at 5:35
  • Have you tried clearing the data of the playstore app? If that doesnt work, try wiping cache and dalvik cache from the recovery. If it's still not working, download the apk from here – Ruben Roy Sep 13 '13 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.