1

I have a Samsung Galaxy S3, which I often use as a hotspot for my laptop when WiFi is out of reach. I have a good deal with my carrier so that I have unlimited and fast connection anywhere. Everyone's happy.

Recently, my connection has been beginning to slow down, only sometimes, so I did some testing, and I found that whenever the connection is slow, and I go into Flight Mode (a.k.a. forcibly disconnect the internet connection), I get an anonymous popup message (The smaller ones at the bottom, not the alert() style ones):

Currently unable to continue download, please try again later.

Now, I didn't initiate any download, so I presume some application is doing it. I've uninstalled everything but the bare essentials, and it still happens.

Is there a way for me to know what my browser is downloading, what kinds of requests it's sending, how much and from where?

  • That message most likely comes from an app. One that I know that causes that is the "espn" app. That is a message presented by it when trying to perform an update. – Zuul Aug 29 '13 at 19:41
  • Further into that issue, other users of your device have reported the same message in relation to the MMSes. Do you have any MMSes on your device? – Zuul Aug 29 '13 at 19:45
  • @Zuul: MMS is a real possibility! I'll check for that! I don't have the ESPN app installed. In the meanwhile, please post MMS as an answer, I'll see if it doesn't return for a few days and accept it if it's that :) Also, ZUUUUUUUUUUUULLLLLLL!!!!! – Madara Uchiha Aug 29 '13 at 19:47
  • If you can, delete all, and repeat the steps taken to get the message... If no message, you're in the clear ;) – Zuul Aug 29 '13 at 19:49
  • The answer is created, please give a feedback on this (either I delete the answer or the comments). Good Luck. Also, :) – Zuul Aug 29 '13 at 19:57
2

I have read in several websites that users with the Samsung Galaxy S3 are getting that exact same message when having MMSes that fail to download (probably old ones...).

If possible, delete all and repeat the steps taken to get the message. If you don't get the message, the problem is solved and in the future we all know from where it is comming.

My original comment on the question:

Further into that issue, other users of your device have reported the same message in relation to the MMSes. Do you have any MMSes on your device?

  • Thank you! I will give it a try, I'll try it several times during the day (because it sometimes happens and sometimes not), and I will let you know if it was it. Thank you!! – Madara Uchiha Aug 29 '13 at 20:09
1

I think a log reader would be able to help you.

aLogcat is a good, free one.

Here's what I would try:

  • Install the App.
  • Run the aLogcat app once to enable logging (not sure if you really have to do this).
  • Repeat what you did before, to make the popup error message show up.
  • Run the aLogcat app again, and check out the most recent logs. It'll probably be in red, and it should identify which app showed the message.

Hope that helps.

Update:
Your comment said that it didn't help. I don't know any specific tools to monitor what app is downloading.

I have used SystemPanel before to monitor the overall phone system. It will shows you upload/download network traffic for the whole phone, and it can also show you what apps are active.

Turn on monitoring in the app, go through the process again to get the error message, then check out which processes show as active during that period.

You might be able to find the culprit that way.

Some screenshots of SystemPanel:

LiveMetrics HistoricalUsage
System Metrics showing recent Network usage, and historical usage (click images to enlarge)

With historical usage of an individual process, you might be able to correlate with the network traffic.

  • I'll give it a try! Thanks! Have my +1 for now :) – Madara Uchiha Aug 29 '13 at 19:12
  • So I tried, I don't see anything special in the log. Nothing in red, and nothing seems related. Any other ideas? – Madara Uchiha Aug 29 '13 at 19:18
  • 1
    Which Android version are you running on your S3? If it's already JellyBean, aLogCat won't see enough anymore (system restrictions). In that case, you could try via adb logcat (see our adb tag-wiki for intro+hints). – Izzy Aug 29 '13 at 19:31
  • @Izzy: JellyBean it is, I'll try adb logcat, thank you. – Madara Uchiha Aug 29 '13 at 19:48
  • 1
    That explains: you most likely saw only aLogCat's own entries then. Good luck with adb logcat. For some more hints: Here's the adb logcat help page, giving the full syntax and some good ideas ;) // Btw: the popup you've described is called a "toast". – Izzy Aug 29 '13 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.