2

I recently rooted my Samsung Galaxy Y. I also used Link2SD to move some of the apps to the SD card partition to free up some space.

Since then I notice this weird behavior. When I go to Logs or Contacts and swipe on a number to place a call, the dialer will not get initiated. The screen will remain unchanged and the call will not get placed. And I will not be able to make calls for the next 5-10 mins.

Then when I try again, the call will get placed normally. But, when I disconnect the call after speaking, the dialer will try to dial the number which failed earlier and I need to disconnect it from dialing.

Also, If I had swiped on the contact more than once when the dialer didn't inititate, then after I disconnect, the dialer will try to place the call the exact same number of times I tried to swipe, in quick succession and I need to disconnect it during each time.

This happens often and is quite frustrating. Has anybody else faced this issue or can anyone suggest how I can solve this? I cannot unroot because I have less memory on the in built memory and I need link2sd to keep the apps installed.

Thanks in advance.

  • Can you move the dialler back to the 'normal' internal storage and not the EXT3/EXT4 partition. Some system apps have gone mad for me over time when Link2SD was used. What ROM are you running? Also have you tried downloading an alternative Dialler to see what happens? Just as a baseline. Do you have a logcat from the device to see if something is happening? – RossC Sep 3 '13 at 9:43
  • @RossC : I have not moved the dialer to the SD card partition. It has been always in the normal internal storage. I am using Stock ROM. I have not tried an alternate dialer yet (Didn't even know they existed until now!!). – SpikETidE Sep 3 '13 at 10:25
  • Give another one a ago. The dialler is just an app on your phone like anything else. It's worth seeing if it works ok. It may be a better alternative or at least a clue as th what is going wrong. Have you tried other ROMS and do they have an issue? Have you asked the dev if this is a known bug? Also it may not be in the internal storage as the EXT partition is internal storage for the purposes of those ROMS / Link2SD. It's obviously not the same but is treated as such. – RossC Sep 3 '13 at 10:27
  • Any luck or update on this? – RossC Sep 4 '13 at 9:02
  • @RossC : I haven't installed a new dialer yet since I am in a place where I will not be able to get on Wifi. But I noticed that this issue occurs only when I enable wifi. After I enable Wifi the issue will be there till I restart the mobile. Weird..!! – SpikETidE Sep 10 '13 at 7:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.