0

I'm trying to get root access on a toshiba AT300 android tablet.

I found this post from google where this guy has tried to get root access.

http://www.thriveforums.org/forum/toshiba-thrive-development/12995-at300-101-ice-4-0-3-rooting-possible-3.html

the problem is that when I run the RunMe.bat file and choose option 1 to root he device a screen pops on my tablet will the heading "Full restore". It asks me to enter the device encryption password below.

I am not sure on where to get my encryption password from. I left it blank and press the "restore my data" button at the bottom of the screen

While the script runs there is a permission problem that I do not understand So I am pasting the whole script below :

======================================================================
= This script will root your Android phone with adb restore function =
= Script by Bin4ry (thanks to Goroh_kun and tkymgr for the idea)     =
=             Idea for Tablet S from Fi01_IS01                       =
=                      (13.10.2012) v15                              =
======================================================================

Device type:
1) Normal
2) Special (for example: Sony Tablet S, Medion Lifetab)

x) Unroot

Make a choice: 1
Checking if i should run in Normal Mode or special Sony Mode
Please connect your device with USB-Debugging enabled now
remote object '/system/app/Backup-Restore.apk' does not exist
remote object '/system/bin/ric' does not exist
.
.

Normal Mode enabled!
.

Pushing busybox....
1314 KB/s (1085140 bytes in 0.806s)
Pushing su binary ....
1082 KB/s (91980 bytes in 0.083s)
Pushing Superuser app
996 KB/s (996704 bytes in 0.977s)
Making busybox runable ...
.
Please look at your device and click RESTORE!
If all is successful i will tell you, if not this shell will run forever.
Running ...
Successful, going to reboot your device!
Waiting for device to show up again....
Going to copy files to it's place
mount: permission denied (are you root?)
You can close all open command-prompts now!
After reboot all is done! Have fun!
Bin4ry
Press any key to continue . . .

I found a Ubuntu ARM version that I want to Install and run on my toshiba AT300 once I am able to root it.

Can someone please help me figure out how to get root access on this device?

0

It looks to me like your device has had encryption enabled on it. If that's the case, you'll have to have the encryption password before you can root it. Was this device issued by your work? I doubt it came encrypted by default, since it adds overhead. I could be wrong though- this is a bit out of my depth too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.