In my stock, unrooted Android 4.3 on a Nexus 4, if I uncheck the feature Vibrate when ringing under Sound Settings, it only turns off vibration for Calls. This does not turn off vibration notification for individual apps (Whatsapp,FB etc). Therefore what I am looking for is an option to turn off vibration system wide, which means the phone should not vibrate for anything, be it calls, text messages or app notifications.
It's like this feature on iOS...when Vibrate on Silent is Off, switching the phone to silent mode turns vibration off system wide.

Is there any app that enables me to toggle this setting?
If Tasker is a suggestion, please provide a detailed description as I am still on the learning curve.

Update 1
Currently (until Oreo) there's no way to do this without having root and installing the application marked as answer below. For Xposed users, there's a free alternative: VibrationTuner

Update 2
It should not come as a surprise, but MIUI has this. Tested on MIUI 9.5.

  • you can use tasker tasker.dinglisch.net
    – Tirath
    Sep 3, 2013 at 12:04
  • Exactly HOW do I use it??
    – Gh0sT
    Sep 3, 2013 at 18:28
  • I would urge people to go to the below link where I have voiced this concern and also linked to this question here and attempt to raise the need of this feature in Android phones. Like, comment, star, do possibly whatever you can in the forum there. This might help get Android team's attention. Controlling Vibration settings system-wide.
    – adityap
    Dec 13, 2018 at 18:10

6 Answers 6


Update: Android Pie (9.0) finally allows you to disable all the vibrations. Go to Settings app > Accessibility > Vibration. Some ROMs still don't have this option, in which case you may want to check out my old solution.

Old solution - applies to Android Oreo or older (<9.0):

Stock Android does not have an option to disable all vibrations. This frustrated me as well, so I made an app that can turn them off system-wide - https://blade.sk/projects/global-vibration-toggle/

A rooted phone is required, as there is no API for disabling vibrations.

The app is basically a user-friendly wrapper for this shell command: chmod 444 /sys/devices/virtual/timed_output/vibrator/enable.

  • I searched weeks for this. Somehow my Poco F1 on Miui 11.0.4 & 11.0.5 disabled this. Feb 13, 2020 at 21:47
  • 1
    The feature seems to be removed again on Android 10.
    – DaVince
    Sep 30, 2020 at 13:43
  • had this working on me before but after factory resetting on android 10, it doesn't get disabled completely
    – harveyhans
    Apr 30, 2021 at 15:09
  • I can confirm that this no longer completely disables vibration. The alarm still has vibration on as default after the change for example.
    – glaux
    Jan 6, 2022 at 9:47
  • On Oneplus 5T, LineageOS 18.1 (Android 11) in 'vibration and haptic strength', I only have options for 'ring' and 'notification' vibration in addition to 'touch feedback'.
    – user598527
    May 14, 2022 at 9:17

Go to Accessibility and set the notification reminder to off. Otherwise, it will keep reminding you every 15 seconds either by sound or vibration.

  • 2
    I'm not sure if this is what the OP was asking about. Doesn't this setting control a periodic vibration that you get while in a call? I think the question is simply how to disable vibration from all notifications. Dec 17, 2014 at 15:24

Under Settings/Sound/Ringtone and notification/Device vibration a choice box comes up with a create button. I just created a vibration pattern with nothing in it and labeled it none. Switched the Device vibration to none and done. Seems to work.


Go to settings - sounds & notifications - other sounds turn off vibrate on screen touch.

  • 2
    That won't change the notification behaviour. It's just a setting for feedback when you touch the screen.
    – Dan Hulme
    Jun 27, 2017 at 10:20

Messaging > Menu (bottom left button) > Settings > Notification Settings > Uncheck Vibrate

  • 2
    This just turns off vibration in the Messaging app. The question is about turning off vibrations for all apps.
    – Dan Hulme
    Mar 6, 2014 at 16:07

Go to Settings →Language and Input→Keyboard & Input Methods→ Andriod Keyboard Settings (gear next to keyboard you use) →Under General uncheck Vibrate on Key press.

Now vibrate should be off for all keyboard presses including the Home key, Back key, and others.

If it isn't then you may need to go to: Settings→Accessibility→Under System uncheck HAC(Haptic Feedback) if it is on.

Now with both "HAC" and "Vibrate on Key Press" turned off, your phone should be vibrate free.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .