I got an old HTC Desire (the first model) which I need to reset.

I've tried to hard reset my phone using the instructions here: http://www.thefullsignal.com/htc/htc-desire/4989/how-hard-reset-htc-desire. But my phone just keeps booting as usual. Maybe I'm doing something wrong?

Are there another way for me to reset the phone? Maybe through ADT or something else?

Edit: I've forgot both which Google Account I used and the visual password (It's an old phone). So I can't log into the phone. That's why I want to do a hard reset.

4 Answers 4


You should be able to wipe via the recovery however, this will wipe all the data on the device including contacts, apps, pictures and videos.

  1. Turn the power off. If your HTC Desire is frozen, pull the battery out and reinsert it
  2. Hold the Volume Down button
  3. Press and release the Power button
  4. You are now presented with a menu that allows for Fastbook, Recovery, Clear Storage, and Simlock
  5. Select Recovery
  6. On the next screen press Volume Up and Power
  7. You should then see the "Android System Recovery"
  8. Select the 'Wipe data/factory reset' option
  9. You may need to confirm your choice (i don't want to wipe the device i have so not 100% sure)

After the phone boots normally, go into the Settings app. Choose SD & phone storage. The last item on the next screen is Factory data reset.


If your phone boots as normal then yes, you're missing the menu you need. When you continue to hold the Vol Down button as it powers on you should see the white boot screen show in this YouTube clip (it's not in English but the process is the same). Once you reach that menu you'll find the instructions you linked to helpful.

  • I don't see that menu
    – jgauffin
    Sep 9, 2013 at 19:51
  • Can you provide any detail about the steps you take to power the phone on? What have you already done to try and solve the problem?
    – Mr. Buster
    Sep 9, 2013 at 19:58
  • I tried following the guide that I mentioned in my question + any combinations of the power + volume button. i.e. holding in both, just tap power etc.
    – jgauffin
    Sep 10, 2013 at 5:26

Take the micro SD card out if it's in. Worked for me.

  • That neither factory-resets the device, nor does it disable the lock. Could you please elaborate a little more what exactly it should solve?
    – Izzy
    Jan 1, 2014 at 0:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .