I have Droid 2 Global (droid2we) and I've tried Power + Volume Up, but that doesn't load any recovery mode. I've also tried Power + X but that loads the standard Android System Recovery <3e>, which won't install unsigned zip files.

I can load the Bootstrap Recovery app which will let you reboot into Clockwork Recovery mode, which does work. However, that requires a functioning system which makes it a pointless way to launch a recovery mode!

3 Answers 3


These are the steps to boot your Droid 2 phone into Recovery Mode should you need to.

  1. Turn Droid 2 Off

  2. Press 'X' on the physical keyboard and then Press and HOLD Power button until the Exclamation Point/Android picture shows(after motorola symbol).

  3. To access menu options Press the "Search" button depicted by the Magnifying glass on the Keyboard and the menu items will show up.

  4. Browse options with the Volume Up and Volume Down keys and select option with the Camera button all on side.

  5. Select first option of "Reboot phone" or risk messing up your brand new Droid 2!

EDIT:- the link to XDA forum that explains you problems

And one more thing if its android recovery that is loading then it means that the CWM recovery is yet not installed

Hence this is the video link on how to install it(CWM)

  • This doesn't work. 1. It's Droid 2 Global. 2. I'm asking how to enter Clockwork Recovery, not standard Android Recovery. 3. Search key doesn't enter menu from standard Android Recovery, but both Volume Up + Volume Down at the same time does. Nevertheless, I need the Clockwork recovery, not standard Android recovery.
    – Chloe
    Commented Sep 2, 2013 at 5:25
  • @Chloe please check my answer I have edited it. And droid2 or droid2 global are same so. although you can visit forum.xda-developers.com/showthread.php?p=26625025 it states the problem you are facing.
    – Tirath
    Commented Sep 2, 2013 at 5:44
  • That still didn't help. I already know how to get into standard Android recovery with the volume buttons. Clockwork Recover IS installed - I can reboot into it from the app. The video seemed promising with Power + R, but that didn't work either.
    – Chloe
    Commented Sep 2, 2013 at 6:46
  • I think you device is temporary flashed I insist you to install CWM in the device again.
    – Tirath
    Commented Sep 2, 2013 at 7:11
  • Perhaps, but I don't know what you mean by temporary. I reset it many, many time and took the battery out and unplugged it.
    – Chloe
    Commented Sep 2, 2013 at 7:49

I found that the following sequence works:

  1. While on, run adb reboot recovery from command line. This will restart into standard Android recovery. (If your device is not seen, start at #2 and come back.)
  2. Take battery out.
  3. Unplug USB.
  4. Hold power down for 10 seconds. (Someone theorized it discharges the capictors.)
  5. Plug USB cable in.
  6. Put battery in. This starts the phone up automatically for some reason. It then loads Clockwork Recovery automatically.

I don't know why this works and Clockwork Recovery didn't provide a standard method to start. This would work in the middle of a failed install of Cyanogenmod. After a flash to a stock SBF ROM, it no longer worked.

  • I've since found that when everything is working, (the phone is not bricked), then Power + Home will start ClockworkMOD Recovery. I'm glad I wrote this answer down because I was trying different ROMs and sure enough, it bricked again! This worked perfectly.
    – Chloe
    Commented Sep 22, 2013 at 7:08

Here's one more experience for anyone looking this up: I can get CWM recovery to boot from ROM manager, but attempting to boot it manually by holding down x didn't seem to work. I got the exclamation mark mentioned here, but the search button did nothing to bring up a menu. However, doing all of this with a USB cable plugged it, then getting all the way to the exclamation mark, I pulled the battery while still plugged in, just for a second or two, then put the battery back in. It automatically rebooted correctly into recovery without the exclamation mark. This is on a Droid 2 Global running various different versions of CWM recovery.

EDIT:or of course, from the link in another answer here, try up and down volume at the same time instead of search button.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .