2

I have several Android phones, with different Android versions. I am writing short messages in several languages (Spanish, Catalan, English, German, Italian, ...) and I am really fed up with Android trying to outsmart me. A simple message takes me ages to write because I need to fight the auto-correction mechanism, or change the language, or whatever.

But if I disable all languages in the auto-correction settings, it still tries to auto-correct in English. Why?

Auto-correction is not for me. I do not want auto-correction, period. Not in English, not in any language. Is this possible?

3

It depends on what keyboard app you're using. If you're using Google Keyboard (the default on Nexus devices), go into its settings. Go to the Text correction section and click Auto-correction. Choose Off from the list.

If you prefer, you could install a keyboard that supports using multiple languages at the same time, such as SwiftKey.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.