1

Brand new stock Samsung Galaxy S3 will connect to Comcast-provided wireless router (Arris brand), but cannot get out of local network - I can ping other devices on the network, and I can even browse the admin page of the router, but cannot get on the internet. Other devices work fine. I've tried turning off security. I don't seem to have the disconnect problems others have reported - the connection is consistent. Oddly, I don't see the S3 listed in the "connected devices".

If I run ifconfig wlan0, it shows the IP address, netmask but no gateway. I can set a static IP, but I still am unable to get internet.

I can connect to other wireless networks without problems.

Any ideas?

Yes, other devices can connect - couple of laptops, kindle, wife's phone, my old phone (both androids) and ipad..

  • Can you get out into the internet with a different device? It may be your router that is not correctly configured. – John Sep 5 '13 at 19:23
  • Often times, when the Arris routers already have multiple devices connected, these routers have trouble, well, routing new devices. What ends up happening is all the currently connected devices keep their routes and the new one is blocked off from the outside world. The best way to resolve this is to let the router completely restart by unplugging it for 10 seconds and then plugging it back in. Then, as each device connects during the start-up, routes will be given to each device accordingly with no trouble. I have this problem all the time with the router we have at work. – user84685 Dec 11 '14 at 16:22
1

Here's what I wound up doing - I reset the router to defaults, and I was able to get conected - I gradually restored everything back to the way I had it (ssid, security etc), and never lost connectivity, so I'm not sure what, if anything is different.

  • Thanks for letting us know what you did to resolve the question. Make sure to accept your answer as correct (once you're able). – Mr. Buster Sep 6 '13 at 22:44
0

I had the same problem with various newer Samsung mobile devices. I restarted my device, went to settings after booting back up, turned off my wireless on the device, then turned it back on. Was able to connect after keying in the security password.

Don't know if this helps. I monkeyed around with this for about an hour. before I got it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.