1

Trying to access a shared folder on Windows 7, using ES File Explorer on my Android 2.3 mobile phone over WiFi LAN.

The scan on APP detects the Windows machine, but am unable to access the shared folder. It shows logon failure consistently.

Tried multiple logins and login names (local user) but in vain.

TCP dump trace reveals the following

60867 5015.029850 192.168.1.2 192.168.1.3 SMB 304 Session Setup AndX Request, User: BLR5898L\shashi; Tree Connect AndX, Path: \192.168.1.3\SHARE

63058 7068.758590 192.168.1.3 192.168.1.2 SMB 105 Session Setup AndX Response, Error: STATUS_ACCESS_DENIED
  • Have you set up any share on that Windows machine? Might be if nothing is shared, you get rejected. After all, the error message you get reads STATUS_ACCESS_DENIED, which means: You've got no permission to access anything. – Izzy Sep 9 '13 at 15:41
  • yes izzy have shared a folder usual sharewith procedure , with everyone all access – Shashi Sep 9 '13 at 15:45
  • 1
    OK, was just a thought. I'm not that familiar with Windoze (I'm using Linux), so I'm out here. From what it looks like, either your provided username/password is mistyped, or it's some problem on the Windows end. You might want to check with Super User for the Windows part, if you get to no solution here (flag your question for mod attention, they can migrate it over; cross-posting is not much welcomed on SE ;). – Izzy Sep 9 '13 at 16:46
1

I had an issue connecting with ESFE to a Win7 PC. This did the trick for me: Go to Network adapter configuration -> Tcp IP 4 settins -> WINS -> Enable NetBios over TCP/IP.

ESFE is looking for NetBios over tcp/ip because android probably doesn't natively run NetBios protocol.

0

When you input the username, use host\shashi where host is the NetBIOS of the Windows machine you're trying to connect to: that is, the name that it's listed under after you scan for machines to connect to.

  • on scan i see the following machine '192.168.1.3' , tried with username '192.168.1.3\shashi' , still no luck – Shashi Sep 9 '13 at 15:19
  • 4087 1340.087753 192.168.1.2 192.168.1.3 SMB 542 Session Setup AndX Request, NTLMSSP_AUTH, User: ?\192.168.1.3\shashi 4088 1340.090191 192.168.1.3 192.168.1.2 SMB 105 Session Setup AndX Response, Error: STATUS_LOGON_FAILURE – Shashi Sep 9 '13 at 15:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.