I got a new phone today same as I had before its a Sony Xperia T I had all my contacts backed up to my Google account but now I can't import them to this phone from my Google account when I sync my contacts nothing is happening does anybody have any idea what I should do?

it always work fine on my other phone when I factory reset it, then when I go to my contacts it's right there to import from Google account, on this phone it's the same but my contacts don't come in there

  • Are you sure you've marked Google contacts to show in your people or contact list? There might be an option to choose which contacts to show like SIM contacts, Google contacts, Facebook contacts,... in your Phone app. Mar 31, 2014 at 8:58

1 Answer 1


Log in to your Google account, use the Play Store or Gmail app. Go to Settings > Accounts and Synch and then go to 'Contacts' and hit 'Synch now'. Your contacts will be under your GOOGLE account. The button may be called something different or just be a 'synch' icon (2 curved arrorws in a circle) but should do the trick. If you have any issues let me know and I'll see what can be done!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .