6

Recently I started to face a very weird bug.

Whenever I try to tap on Create alarm button, or on existing alarm

I am getting this "Unfortunately, Clock has stopped"

This is a system app I don't know what to do now.

What it could be?

What I tried:

  1. Delete Data from App Manager
  2. Clear cache
  3. Restart the smartphone

Some info:

  1. default (but upgraded) firmware - Android 4.1.2
  2. Device Galaxy Note II GT-N7100
  • Can you use adb logcat to get more information about the crash? – Trebor Rude Mar 18 '14 at 9:34
4

I had a similar problem but on another device, though try if it can fix your problem this is the what I did:

I opened the Terminal Emulator and typed:

$ su 
# logcat 

Then I held 'Volume down' (a.k.a. Ctrl) and 'c' to stop the output. I scrolled a bit up in the output and found a line that said:

E/SQLiteOpenHelper( 5231): Couldn't open alarms.db for writing (will try read-only): 
E/SQLiteOpenHelper( 5231): android.database.sqlite.SQLiteException: Can't downgrade database from version 7 to 5 

OK, so this is where it's breaking. I wasn't really interested in finding out what should the proper combination of ownership/permissions for the file as I didn't really trust it would end just here, downgrading database version offers a range of situations that can go wrong. And since I don't really care for my past alarm clock times, I got rid of the old database:

# cd /data/data/com.android.deskclock/databases 
# mv alarms.db alarms.db.bak 

otherwise at the time I looked out for this problem the only other solution I saw was to wipe and restore my phone. If you do so, don't forget to backup all your data first!

Good luck, I hope it helped you or someone.

  • 1
    just a note: device has to be rooted – bakytn Apr 8 '14 at 7:02
  • 1
    I finally rooted my device and tried this solution. I couldn't see the problem: "E/SQLiteOpenHelper" but still wanted to try. though the package called "com.android.app.clockpackage" instead of "com.android.deskclock" and alarms.db is called alarm.db in my case this didn't help – bakytn Apr 12 '14 at 18:23
1

So finally I was able to fix this weirdo.

Since this answer doesnt really tell what was causing this. I will remark any further answers if they can tell what was the problem

I will just describe what I did.

  1. Root your device
  2. Install Clean Master
  3. Give it the root access (it will ask itself)
  4. Remove all bloatware
  5. Run cleaning routines
  6. Hope that it helped you
1

Clock has stopped when editting or creating alarm after updating to Lollipop.

I notice the solution for me is this issue only occur when my phone is in silent.

You can edit the alarm or create another alarm when your phone is not in silent mode.

other solution is do not put your phone in silent mode instead put the volume down

0

Make sure your phone isn't on silent! I had the same problem until i realized that i was using the profile Silent and for some reason this didn't allow me to set the alarm. After changing to Default profile the problem was fixed.

  • 1
    I tried it with no success. There's probably another reason. Anyway, recently my device has started to be slower than usual, probably there's some hardware error I suspect it's a system flash memory problem. – bakytn Sep 26 '13 at 16:30
0

This weird phenomenon came into my phone too..(Huawei honor6) This might be helpful to those who are panic struck! There is no need to worry..just follow the given below instructions and that might allow you to access the clocks again .

Clear cache data...either by using app or system app Turn up the phone volumes And if the above two doesn't work just reboot your phone.... Hope this helps you recover your accessibility to clocks

  • this didn't help me – bakytn Mar 16 '15 at 8:22
0

I just called Verizon Wireless tech support back. The guy had seen this problem once before and found a fix for it. I haven't seen this fix posted on any website, but it worked immediately. Please let me know if this works for you

Go to Settings--Date and Time--Select Date Format, and then choose a date format. Once I picked 'regional' the clock worked without the error "unfortunately, clock has stopped"

Before I tried clearing cache and doing a factory reset You don't have to do this if this "choose date format" works. Please comment and let me know if this helped you. I'm curious if this will work across the board. Maybe even for phones other than Samsung Galaxy S4. I'm stoked!

0

I had a similar problem on my fresh S5 (after manually adding an adb backup, so the data might not have been so fresh after all). However, I managed to get rid of the problem without rooting the device:

This is what helped me solve the issue:

$ logcat
...
D/MediaProvider(29294): Upgrading media database from version 601 to 713
...
E/DatabaseUtils(29294): android.database.sqlite.SQLiteException: ...

Apparently, a database upgrade failed (so yes, android or some app does attempt to solve these kind of problem but do not interact with the user in any meaningful way, i.e. offer a fresh reset). However, the culprit here, the media database could be reset via the app manager (media storage app).

I hope this helps others that get into this issue.

-2

After DB deletions, cache and Dalvic cache clearing, Silent mode was the culprit.

protected by Community Jul 5 '15 at 16:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.