0

Please, I have a device wich I connect via bluetooth from my Samsung Galaxy S. The bluetooth device have a alphanumeric PIN. When I try connect it ask for PIN but my galaxy only let me to put numbers!. Android 2.1 let me put numbers and letters. Any suggestions? PD: Impossible to change the device's alphanumerical PIN.

Thank you.

02/02/2011. Question solved. It was as I thought. Update 2.2.1 allow to put numbers and letters in bluetooth PIN(like in 2.1 version).

7
  • I've edited the tags because the question seems related only to Android.
    – Radu Barbu
    Jan 27, 2011 at 12:01
  • If I switch Swype keyboard I get the letters but they don't show on the screen...
    – Alex
    Jan 27, 2011 at 12:20
  • This seems more of a hardware/software issue than a programming issue.
    – Jamie Keeling
    Jan 27, 2011 at 12:26
  • Hi TheCottonSilk and Jamie Keeling, Almost i am sure the problem is anything about froyo 2.2... I can switch mode ABC when DialogBox appears asking PIN, but I pulse any letter and it doesn't show in the EditText. It is like if the DialogBox had a filter to accept only numbers. The problem is that this DialogBox is controlled by the O.S... :(
    – Alex
    Jan 27, 2011 at 14:19
  • Hi TheCottonSilk and Jamie Keeling, Almost i am sure the problem is anything about froyo 2.2... I can switch mode ABC when DialogBox appears asking PIN, but I pulse any letter and it doesn't show in the EditText. It is like if the DialogBox had a filter to accept only numbers. The problem is that this DialogBox is controlled by the O.S... :(
    – Alex
    Jan 27, 2011 at 16:52

2 Answers 2

1

Looks like its device related issue than Android OS issue.
If its a firmware related issue, vendor may be able to offer you a patch.

Meanwhile if you see an option to switch between Number mode and ABC mode on your keypad, you can try that..

Refer page 29 of device manual.

1
  • 1
    Haha - if it is truly related to the Samsung TouchWiz build of android... good luck waiting for Samsung to fix it. Jan 27, 2011 at 14:52
0

Here you could see a video that shows this issue:

http://www.youtube.com/watch?v=e3MV7m-KZHM

Update from comments: Question solved. I have already update my Galaxy S to 2.2.1 and It allow put numbers and letters in bluetooth PIN !!!

7
  • @Alex: This should have been an update to the original question. Since you haven't registered either here or at Stack Overflow, you aren't associated with the question. I suggest you do so, then you'll be able to edit and comment here as appropriate.
    – ale
    Jan 27, 2011 at 17:06
  • Sorry Al Everet, now I am trying edit my question... But I don't know how I do this..
    – Alex
    Jan 27, 2011 at 17:09
  • Because you don't "own" the question. It was migrated from Stack Overflow. To restore ownership to you, you should register at both Stack Overflow and here with the same credentials. Then (eventually) the question will be associated with your account.
    – ale
    Jan 27, 2011 at 17:13
  • Ok, sorry for my mistake.
    – Alex
    Jan 27, 2011 at 17:21
  • No problem. We're here to help.
    – ale
    Jan 27, 2011 at 17:30

You must log in to answer this question.