2

Is there any way to get rid of the useless little toast announcement informing me that I have put the device in range of the charger?

I would prefer a solution that works with the stock ROM (JB 4.1). I do have root.

2

This answer works for the Galaxy S4, but it will likely work for your S3 as well.

Install the xposed framework, which is a soft-mod framework that lets you modify your current rom (including the original/stock rom) without permanently changing it (you can enable and disable modules at your discretion). The framework and modules, of course, require root.

After you install the framework, install the Nottach Xposed module. This is designed for the S4, but most of the features work on the S3 as well.

After installing the module, enable the module within the xposed app. Open the Nottach Xposed app (acknowledge the warning that it isn't made for your device), enable the checkbox for Framework->Hide wireless charging dialog. Finally, reboot the phone.

Your phone should now be able to charge wirelessly without having the dialog pop up every time. Many of the other options in Nottach Xposed will likely work, though obviously tweaks for things that only exist on the S4 won't work for the S3.

  • Attempting to install any version of the Nottach module just gives me "There is a problem parsing the package". – Compro01 Sep 13 '13 at 15:04
  • Looks like it may require Android 4.2. After looking further, people got it to work just fine on the S3, but only after they had updated to 4.2 (with a custom rom). – Stephen Schrauger Sep 13 '13 at 15:17
  • In a month (October 2013), your S3 should receive an update straight to 4.3. Then this solution will work for you. Update announcement: ibtimes.com/… – Stephen Schrauger Sep 13 '13 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.