I have a Samsung Galaxy Discover that worked fairly well until the last week or so. I ran the device down down to 0% - at which point the device shut off. I performed a full recharge and then occasionally recharged it for brief amounts of time (usually getting to 30-40%).

My battery graph ended up looking something like this:

enter image description here

Then earlier today, I performed a full charge to 100%. The device shut off after a few moments and insisted that the battery was at 0%. I plugged it in and the meter now stays at 0%.

I'm not sure if this is relevant, but I discovered that the voltage is being reported as 4195 mV (the so-called 0%). However, a few days earlier, I remember that the phone seemed to think that about 3800 mV was 0%.

Is there a way to "reset" the battery meter? In other words, I need to tell the phone that it actually has a full charge even though it seems to think otherwise.

Update: the battery was eventually replaced with a brand new one and the issue continues to persist - even with the new battery. Interestingly, the battery seems to charge and operate correctly when the battery temperature is above 30° C.

  • I've found a way to artificially discharge the battery - recovery mode. The phone ignores the battery state and keeps the screen on - which works perfectly. We'll see if that helps. Sep 14, 2013 at 14:10
  • have you tried calibrating the battery?
    – svarog
    Jan 24, 2014 at 11:09

4 Answers 4


Wife had a somewhat similar issue. I went into recovery mode and formatted the cache and it solved her problem. To get into recovery mode it is usually Hold volume up + power, let go of power once the phone vibrates but keep holding volume up.


I don't know if you're rooted or if you have custom recovery or not, but in some of the later versions of ClockworkMod recovery there is an option to "delete battery stats". Without root, there seems to be no way to reset the battery statistics.

  • 3
    Whether the phone thinks the battery is full or not has nothing to do with battery stats: plus.google.com/105051985738280261832/posts/FV3LVtdVxPT
    – user5506
    Feb 25, 2014 at 14:02
  • Thanks a lot for that information, I didn't know that. But he was asking for a possibility to reset, wasn't he? Or did I not understand him correctly?
    – VollNoob
    Feb 25, 2014 at 14:22
  • You can reset stats, sure, but my understanding is that those stats tell the device which apps used the battery; sounds like his problem is that the device has no idea how much power the battery currently holds, and that doesn't appear to be held in the stats.
    – user5506
    Feb 25, 2014 at 14:28

You can recalibrate the battery. What happened is you battery status file is corrupted. Use a battery calibration app from playstore and recalibrate battery.If it is rooted go to recovery and wipe battery status and do calibration


I had the same issue with my phone, it is nothing to do with OS. It is an issue with the battery, I strongly recommend to buy a new battery and replace the old one. Hope this works for you.

Ok guys, lets share what we have down yet,

  1. I have changed the battery and it was a good idea but does not solve the problem completely
  2. I used another USB charger and did not work
  3. I have wiped batterystats.bin and it did not work
  4. I have use some apps and they made a mess and nothing happend
  5. I let the battery drain(completely) and recharged that. It was useful but did not solved the problem
  6. I know that battery configuration is under /sys/platform/. There are some files inside (for me the folder is mt-battery) that I guess they show the voltage and ... maybe some experts can modify them for us to solve the problem.

I guess 1 and 5 have more or less solved the problem for me.

finally I found the solution:
For me the problem was nothing to do with the battery. It seems a problem in the kernel of OS cases all the problems. As far as I discovered, if cpu is under heavy load then the kernel might crash and lost the control over hardware especially the screen and battery.

I also have found the permanent solution I downloaded a CPU control app (you need a rooted device) and set the cpu clock to a lower frequency and set the governor to Ondemand (that I found the most reliable one). Then you need to wipe battery stats and cache(it is up to you) and enjoy your smartphone.

No My mobile phone works fine, no lag, no battery drop.

  • Unfortunately, it didn't work. Please see my update. Mar 9, 2015 at 23:43
  • As far as I know, when I charge my mobile phone the charging percentage changes suddenly in some points. For example it is 10% and suddenly it increases to 20%. When I use that, the reverse happens. I mean when I touches 20%, it suddenly goes down to 10%. Previously I had 3 or 4 gaps like that I described. I am not sure if my solusion works or not (or even it is correct to do that). I removed the battery and put that on a flat surface and rolled my pencil on that slightly (with some pressure). Now I just have one gap between 41 and 57 and nothing more.
    – TPArrow
    Mar 10, 2015 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .