5

I'm running ubuntu 12.04 and have a rooted samsung galaxy s4. The s4 is still 2 software versions back since I need to unroot to update and just havent had the time or energy to do all of the work to get back to where I'm setup. I think it is 4.2.something.

So when I plug my S4 into ubuntu via usb I get an error message

"Unable to mount SAMSUNG_Android Error initializing camera:-60: could not lock the device"

With my rooted kindle I run gMTP and that gets me access so I tried it with the S4 and it says nothing is available to connect.

With my old evo I had no trouble. Even when it wasn't rooted I had access to the sd card just like any other drive being mounted. What's the deal with this s4?

I do have usb debugging enabled.

  • Galaxy S4 uses MTP so you will need to turn debugging off and it should work with gMTP – Zac Powell Sep 14 '13 at 20:38
  • I believe I have debugging on on the kindle and gMTP still works. I'll have to confirm this later. I might be wrong. – hortstu Sep 15 '13 at 3:00
5

Open a terminal in ubuntu(ctrl+alt+t) and type this commands:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp
sudo apt-get update

Then, launch Software Updater (previously known as Update Manager) and install the available updates. Afther you pdate everything restart pc.

if you want to revert back before making any changes:

sudo ppa-purge ppa:langdalepl/gvfs-mtp

Next time, I think you should ask this is askubuntu.com since it is more of a linux specific problem then android.

  • Thank you but what exactly does this do? Is this just updating gMTP? The reason I ask it here is b/c my ubuntu box has no problem recognizing my old HTC evo. In fact it just opens like any mounted drive automatically as long as I unlock the home screen. While access is the first step I'm trying to achieve I ultimately want to be able to skip jumping through hoops and just unlock my S4 plug it in to the USB and be in business. – hortstu Sep 15 '13 at 2:59
  • 1
    Can anyone tell me what rat2000 code will do? I don't like to enter code without having a basic explanation. Maybe I should ask this at the ubuntu forums... – hortstu Sep 15 '13 at 5:40
  • This worked and got me directly to the desired result. I recieved an explanation for what the code does here askubuntu.com/questions/345735/… – hortstu Sep 15 '13 at 6:04
1

I had the same problem a while back. Make sure USB Debugging is disabled in the Developer Options menu.

  • @geffchang I have USB Debugging enabled and I'm having no trouble mounting the rooted device or the sd card. I followed the directions posted above by rat 2000 and never had to disable usb debugging. It just works now. Check it out. – hortstu Sep 20 '13 at 3:14
  • @hortstu Thanks, but I was just editing AbandonedGoat's post. – geffchang Sep 20 '13 at 3:25
1

So far I found issues like if you have your USB Debugging enable or connect it through USB 3.0 then get this error. So either you disable that option or connect through USB 2.0 would work fine. Or best you can do is what @Rat200 suggested here I had exact same problem. Hope the answers the question.

Btw It's more of Linux specific problem not android.

  • Worked well. Confirmed it was not a USB cable problem by checking Samsung device appeared after launching lsusb, but an USB 3.0 port issue. – KrisWebDev May 18 '15 at 21:04
0

Have you tried connecting the phone using the usb mass storage option on the device? I usually do that with my S2 to work.

  • Where would I find that option? I've explored settings pretty extensively and didn't see anything along those lines? – hortstu Sep 15 '13 at 5:39
  • Have you tried the method here? link. – Mihai Boisteanu Sep 15 '13 at 6:04
  • The method suggested by rat2000 worked for me. Thanks for your help. – hortstu Sep 15 '13 at 6:11
  • I'm glad it did. – Mihai Boisteanu Sep 15 '13 at 6:12
0

I had the same problem when I connected via a USB 3.0 port, but USB 2.0 on the same notebook worked fine.

-1

Trying a different USB port and restarting the ADB server worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.