I have a 1st gen Nexus 7 and I've been having trouble copying files to and from my Nexus 7.

The first problem is that when I plug my N7 into my Windows 7 PC, using the factory cable, the device shows up in My Computer, then immediately disconnects, then reconnects then disconnects and finally connects. This is so infuriating as for about 15 seconds it's just showing then disappearing constantly.

Once its' finally connected, I'll navigate to a file and drag it to my PC, to copy. As soon as that happens, an error box saying "A device attached to the system is not functioning". Then the explorer window disappears and my device has to reconnect.

It's driving me mad, it's not worked for about 6 months and I'm at the point of smashing it with a hammer. I've completely re-installed Android from Google's stock ROM. I've re-installed the drivers on my PC, got rid of the ADB drivers.

Any ideas?

  • This doesn't seem to be a software issue. Everytime I had an issue like that, it was because of the cable, try getting another cable and see if it works. Sep 17, 2013 at 7:51
  • I've been able to use ADB successfully to push stock roms, so I'm really not sure if it is. Though I'll be sure to try another cable.
    – Nathan
    Sep 17, 2013 at 8:59

6 Answers 6


I was having a similar problem. What I did was install ES Explorer on my Android and use the LAN option. On the PC I setup a share folder(s). In ES Explorer I went to the folder with the file(s) I wanted to transfer, I copied them. From there I went to LAN page and tapped on search, takes a few seconds, then tapped on icon for my PC (192.168.x.x.x). Then choose where I want to put the file. Real easy work around

You can also use ES Explorer to transfer between other devices (wifi hotspot, Bluetooth, FTP...)

Good luck!!!


First off I wholeheartedly agree this isn't a cable issue. There are all sorts of bugs I'm finding with android kitkat. I also got this error. I was copying about 5 folders of music and a single song. Two folders copied fine before i got the error. Brute force re-attempt and the second time it started but timed out, at which point it lost connection to computer.

I had to reenter the password to unlock the device and it showed in windows again. This time, instead of letting the screen timeout, I purposely pressed the power button to put the screen to sleep. This time the connection stayed and the transfer completed successfully.

Try turning the screen off after it is connected to the computer.


In addition to FTP server for file transfer, you can also try an app like Airdroid or ES File Explorer which will allow you to transfer files using wifi. MTP protocol is cumbersome and not very stable. There might be an issue with Nexus drivers on your PC. Have you tried copying from another PC?


This problem is related to drivers installed by windows for the usb to nexus, there are solutions for the nexus 4 and 5 which require you to remove this in hardware settings, and replace with someone other than microsofts driver, wifi is probably an easier solution if you have a router


This certainly isn't a cable issue, as Raghd Hamzeh suggets. I have (had) exactly the same problem with 2nd generation of Nexus 7 tablet. In my opinion, it is a very poor, weak and unstable MTP protocol, that you have to use on any Android 4.x, which is responsible for your problems.

The only fix or work-around to this problem (to not to break my tablet with a hammer), I found out, was as stupid as setting up local FTP server (Baby FTP Server was ideal for this kind, one-time solution) and installing FTP client to my Nexus and then copying files that way, through FTP protocol.

I know, that MTP protocol is very, very unstable and forcing users to use it (i.e. removing native USB support in Android 4.x) is a Google very not funny joke. And it thrills me, that I have to use such stupid solutions, to solve such obvious things, like copying files to my own mobile device.


Try a different USB port.. I worked beautifully for me!!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .