1

I have installed CynogenMod7 (Jordan) on my Motorola Defy using ClockworkMod Recovery.

The phone boots up, first with a screen saying "Google" and then an animation of the Android mascot skateboarding into a cyan circle with "Cyanogen7(mod)" appearing at the bottom.

The phone then goes into a loop of this animation - the mascot skateboards in, the circle and name appears - repeat.

I have been unable to enter "fastboot" mode (by pressing power button along with volume up+down keys). I did do a back-up of my previous ROM onto my SDCard.

What should I do to fix this?

  • I can get into "bootloader" by pressing the power button along with the volume+ button. – BaronGrivet Sep 18 '13 at 21:42
  • 1
    Are you able to get into your recovery? It may be easiest to do a full wipe and re-flash the CM ROM from scratch. – RossC Sep 19 '13 at 7:36
  • Have you tried anything yet? There seems to be the same opinion below as what I suggested... Any feedback? – RossC Sep 20 '13 at 11:07
  • @RossC - I couldn't boot into Clockworkmod, but I could boot into bootloader. So I installed a new SBF image. See my answer below. – BaronGrivet Sep 21 '13 at 0:41
  • Great, I'm glad to see you got it sorted out and posted the steps! We've all had that fear before! – RossC Sep 23 '13 at 7:30
4

Thank you for your answers everyone. Unfortunately I was unable to boot into Clockworkmod Recovery.

Fortunately I found the following solution:

  1. Downloaded and installed RSD Lite (on Windows 8 Professional x64)
  2. Downloaded and installed the Motorola USB Drivers
  3. Downloaded a SBF image from here: http://sbf.droid-developers.org/umts_jordan/list.php
  4. Started RSD Lite
  5. Booted the Defy with Power and Volume Up buttons
  6. Plugged the Defy into my computer via a USB cable (my USB3.0 hub seemed to cause problems so I plugged it directly into a USB2.0 on my laptop)
  7. Inside RSD Lite I selected the SBF image file on my computer.
  8. Selected "Uncompress and Start Flashing" in RSD
  9. Waited for phone ROM to get flashed.
  10. Enjoy working phone

Just as a note - if you run into any annoying Motoblur authentication issues you may have to do a factory reset on the phone. This will clear all your user data and can be done in the follow way:

  1. Boot the Defy with Power and Volume Down buttons
  2. The Android mascot with the triangle/exclamation mark should appear
  3. Press both the Volume Up and Volume Down buttons at the same time
  4. You should enter the standard "Recovery Mode"
  5. Use the Volume Up/Down buttons to navigate the menu items
  6. Select "wipe data/ factory reset" with the Power button
  7. Confirm
1

That is a boot loop. You will have to re-install your CyanogenMod again.

You have to hold volume down and power for about 5 seconds to enter clockwork.

You have to keep trying, I sometimes have the same problem. Just try and may by you will get in recovery, so you can reinstall the rom again. Also when you are in recovery make a full wipe of your phone to.

I usually do it: pull battery out and at the same time as putting it back in hold volume down and power for about 5 secconds.

0

1) Power off phone by taking out battery

2) while phone is off (and battery is in) hold power AND volume down buttons at the same time. This should put you into bootloader. Scroll to recovery and select so you can boot into recovery.

Next, factory reset, clear cache, wipe davlik cache, and try re-flashing CM7

  • first he should retry flashing the rom. If this fails resort to factory reset. – Th 00 mÄ s Sep 19 '13 at 14:13
  • He's already tried to flash the rom. – darknight Sep 19 '13 at 15:35
  • he tried flashing it once. Doing it again often yields the result of getting out of the bootloop. Cant say why but personally experienced it more than once. Its worth a try. – Th 00 mÄ s Sep 20 '13 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.