Due to my profession I use to have to connect to wired-only LAN-attached devices (like managed switches, routers, set-top-boxes etc) frequently to access their configuration interfaces via Telnet/SSH/HTTP. And I am totally tired of carrying a bag with a laptop with me wherever I go.

I have just bought a Samsung Galaxy Ch@t B-5330 (Android 4.1.2) smartphone (almost the only modern model with a physical QWERTY on the market today, certainly the only QWERTY by Samsung) and an USB-OtG ("USB host") cable for it.

It would simplify my life significantly if I could connect it to wired Ethernet networks.

Is this possible? Where do I even start?

It seems to be no custom firmwares like Cyanogen Mod available for my particular model but I am most probably going to root it.

I've got a USB NIC based on ASIX AX88772 chip (which is detected by Ubuntu out of the box and is said to be compatible with XBox, PS3 and Apple Macs so it seems to be a very standard kind).

Also, I have not even found a single USB device (I have tried an USB flash drive, a keyboard and a mouse) which would work with the Android phone. It seems that they don't even receive power from it. Perhaps it (USB host mode) should be switched on somewhere in settings? I couldn't find where.


3 Answers 3


According to GSMArena, this phone doesn't support USB-OTG. That would explain why none of the other devices you've tried worked.

In that case, there's nothing you can do to make USG-OTG work, and you can't use a USB ethernet adapter.


I have tested following phones which work with micro usb otg cable to ethernet (i.e have build in ethernet drives).

Asus 1. All models of padfone ()only the phone part, not when docked to tablet). When otg usb to ethernet adapter is attacheds (or otg cable attached with usb to ethernet adapter, then ethernet menu pops in on the setting menu as well as on the notification bar.

  1. Sony Most Sony phones have ethernet drivers built in so they work, but no notification pops up. just switching off w-fi and data and using the browser will confirm that you have ethernet connection

  2. Google Nexus Nexus 5 and Nexus 6 (but not Nexus 4) have ethernet drivers built in so they work, but no notification pops up. just switching off w-fi and data and using the browser will confirm that you have ethernet connection.

  3. Motorola Moto G (2013 edition, 2014 edition). Moto X (2013 edition and 2014 edition)

Following brands phones do not work with ethernet cable as the drivers have been removed Samsung, LG , HTC, Huwawei.

  • I found on a Samsung SM-T530 tablet running Android 5, when I attach an OTG adapter with USB to Ethernet, it connects to the attached ethernet cable automatically; there was no need to change any settings. Using a Lenovo tablet running Android 6, everything worked out of the box as well, only I found the tablet to reboot itself consistently after moving data over the Ethernet connection!
    – MichielB
    Commented Apr 25, 2017 at 12:50
  • In addition to ethernet drivers, as in "android even supports the protocol", drivers for the individual physical controllers hardware are required (you can check kernel defconfig to see if OEM included them to begin with). The tablet rebooting is very likely indicating you are hitting bugs in these.
    – mirh
    Commented Mar 16, 2019 at 18:37

Old post, but anyways ... My suggestion is to use a small portable router (like TP-Link WR702N), set AP mode, connect it to Ethernet and then connect the smartphone to router's WLAN. This way you will bypass the lack of OTG capability of smartphone's (or tablet's) USB port. Never tried, but this should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .