6

I recently bought a HTC One. Everything worked fine including mobile-data and Wifi. Until I once used my phone as Hotspot for my laptop.

The whole time while using the hotspot I had working internet on both my phone and laptop. But the next day (hotpost disabled), I couldn't get the mobile-data to work.

I don't get an error, it just doesn't load.

Wifi connections still work.

Now I tried reenabling hotspot and to my surprise it works. I now have internet on the laptop but NOT on the phone.

It seems that somehow the mobile-data will only work when the phone is used as hotspot.

What have I done wrong?

Android 4.2.2

10

Somehow there was a proxy set up in the APN settings …

Edit: To change the proxy you have to go to the settings and click on mobile data. Select Access point names, select the active APN (or the one you're having problems with) check/reset the Proxy/Port settings.

  • @dot: Pit will have to wait two days for that. – ale Sep 19 '13 at 13:17
  • 2
    @Pit: It would be nice to have the steps to reach those settings for future readers who find themselves in this situation. – ale Sep 19 '13 at 13:18
  • @AlEverett I added the steps to reach the settings – Pit Sep 24 '13 at 7:13
0

If you're using Android 8, follow the Path Setting -> Network & Internet -> Mobile Network. Change to the tab the represent your active cellular SIM (in case of dual-sim phones) -> Access Point Names -> [3 dots icon] on TOP RIGHT -> Reset to default. Worked perfectly for me right after reset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.