1

I am trying to flash a recovery-image file into my Nexus 7 but the flashing fails

know that I am working on windows and my image file is located in the same folder as adb and fastboot files are

here are the steps I am following:

  • start the tablet android system, and the device works fine
  • I restart the tablet into the bootloader using: adb reboot bootloader
  • browse to the Recovery Mode and then check if the adb sees the tablet: fastboot devices
  • adb is working fine and can detect the device and read its serial number
  • then when I flash: fastboot flash recovery recovery-clockwork.img: I get this error:

    error: cannot load 'recovery-clockwork': No error

what am I doing wrong ?

  • Just to make sure: the file you are going to flash is named recovery-clockwork.img, and located within the same directory you are working from? Have you tried with a full path? – Izzy Sep 26 '13 at 11:08
  • @Izzy: Yes, it is name is recovery-clockwork.img, I removed the version numbers and put it within the same directory I am working from .. but no, did not try the full path yet .. – McLan Sep 26 '13 at 11:22
  • @Izzy: yes it works.. the mistake was, after adding the adb path to my environment-settings, I keep opening the cmd and then run the fastboot flash command .. so it was c:\User\User1 .. now, I change the working directory to the platform-tools folder ..c:\...\platform-tools .. and the flash command worked – McLan Sep 26 '13 at 11:29
  • OK, I did! Glad it was that easy :) In fact, I didn't expect that, as the error should have been something like "no such file" then... – Izzy Sep 26 '13 at 15:06
  • @Izzy: me too, was excepting something more complicated, but, luckily, it was not .. btw, it gives me the error "no such file" when I wrongly state the file name .. – McLan Sep 27 '13 at 15:42
0

Most common errors (and solutions to them) are:

  • different file name: make sure the file is really named recovery-clockwork.img, in your example, or adjust your command according to the file name
  • wrong path, e.g. your file resides in C:\Downloads, but you're executing fastboot flash recovery recovery-clockwork.img from C:\: Either first change to the directory the .img file is located in, move the .img to where you want to execute your command, or try specifying the file with its full path (e.g. C:\Downloads\recovery-clockwork.img)
  • sometimes adb/fastboot behaves strangely when executed from "somewhere else". In those cases it helps to first changing to the directory where the resp. executable is located, and run your command from there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.