2

I use a Samsung Galaxy S III and I use the stock Samsung email application and widget (which also comes stock on the Samsung Galaxy Tab 2).

I have four gmail accounts linked to my phone and I have all four gmail accounts configured for use with my stock Samsung email app (this is different than the gmail app available on the Play store).

IMAP is enabled in my Google accounts and all settings match those recommended by Google.

However, when I send an email from my phone the message doesn't appear in the sent folder, in my phone. Oddly enough, the message does appear in the sent folder on my PC when viewing gmail in Chrome.

I believe that this error is related to Google's 2-step verification security settings. I remember having this problem about six months ago and that was about the last time I had 2-step security active. I don't remember how I fixed the problem, but it hasn't been an issue for a while. But since that was about the same time I tried (and then gave up on) 2-step verification, I'm guessing that this is the issue.

I recently enabled 2-step verification, then I had the problem with my email, then I turned off 2-step verification, and then the problem went away.

I am well familiar with application-specific passwords and I have set them up (properly, to the best of my knowledge). I also have Google's Authenticator app, and have used that when required.

I believe there is a bug in Samsung's email app that prevents outgoing mail from being saved in the sent folder when 2-step verification is active.

However, if anyone knows for sure what causes this, and whether or not there is a fix for it, I would greatly appreciate any help.

  • I think you're on to something. I too turned on 2-step verification around July, which is when I noticed this same issue. I do, however, like the 2-step verification. It was a pain in the butt to get started, but I do feel much better using it. To add to this issue, I did notice that, in the Gmail client (browser based), I have a "Sent" folder and a "Sent Gmail" folder. This likely has something to do with the fact that I have Gmail set up in Outlook 2010 using IMAP. So this issue only seems to happen when sending mail from my Galaxy S4 using the stock mail client. Mail sent from this device d – user46969 Nov 26 '13 at 16:02
  • I bought an Android phone a few days ago... and it has the same problem. I don't know what causes it; but if it's a bug, it's amazing that by 2016 it still hasn't been fixed. – Zenadix Jan 11 '16 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.