Yes, I do have that phone, rooted few seconds ago. Anyway, is practically impossible for me to be able to mount my MicroSD and/or phone's internal storage on GNU/Linux even if the USB mode is turn to "MTP". On my father's laptop that runs Windows, I can plug and open the folder about my phone and then select between mounting either the MicroSD or the internal storage.

So, How can I mount my MicroSD or phone's internal storage on GNU/Linux?


1 Answer 1


Wow, I had this problem just this week! And just got access to my MicroSD...

Accessing your MicroSD

The Problem:

My MicroSD card works GREAT on my phone, but when I inserted it into my card reader and plugged it into the computer (Ubuntu 12.04), it didn't read! Well, this MicroSD card was a 16GB, Class 4 so I thought maybe it was due to the Class that it didn't work. Since, when I plug in a 2GB MicroSD, it works great! Works on my phone as well as using the card reader.

What I did:

Updated my USB drivers as well as my computer and it's all GREAT!

Here's the command that I used:

sudo update-usbids && sudo update-pciids

And then use the Software Center and just do a full system update. That's it.

The post where I got the info from: Ubuntu 10.04 USB drives not mounting! - These are instructions for Ubuntu 10.04 but it worked for my 12.04. *I didn't have anything to do with mount-manager at all.

Accessing your internal storage

This is something that I'm not an expert at but I'm quite sure it's what the rooting program using the ADB connection did to my Android when it needed to install the sudo binary.

But here's a link I hope will be of a great help to you - How to access intenal storage or internal memory of Android while conecting to PC?!

  • For full storage access, you might want to take a look at adbfs, see my answer here. Works perfectly for me on my Ubuntu 12.04 machine.
    – Izzy
    Sep 28, 2013 at 13:44
  • I don't use Ubuntu but Parabola, but thank you, I'll try to update my usb.ids and playing around with ADB if possible...
    – shackra
    Sep 29, 2013 at 1:14
  • doing sudo pacman -S gvfs-mtp mtpfs solved my problem :), watch! Imgur
    – shackra
    Sep 29, 2013 at 4:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .