2

Can't connect to Wifi on my phone, because the ON/OFF slider is grayed out:

Screenshot
Screenshot (click to enlarge)

Also, the WiFi icon keeps blinking, and I can't turn it on/off. Kinda frustrating.

Android Jellybean.

  • 1
    Have you rebooted? Have you charged? – Liam W Sep 29 '13 at 21:41
  • You can use the Android debug bridge to investigate: "adb shell" then "dmesg" and "logcat" will give you the kernel's and Android's logs. – ce4 Sep 30 '13 at 6:11
  • I did reboot my phone, did a factory default reset, it still has the same error :/ – user42362 Oct 2 '13 at 17:05
  • How do I use the debug bridge? I'm kind of a n00b here lol – user42362 Oct 2 '13 at 17:05
1

I solved it by deleting /data/misc/wifi/wpa_supplicant.conf. It will reset all your saved networks. I have it rooted and deleted the file through a root explorer or you can remove it via ADB (adb shell rm -r /data/misc/wifi/wpa_supplicant.conf. I'm not sure).

You may backup it before, then open with a text reader to see your saved passwords.

0

First of all, this topic is long dead, but still couldnt stop myself from posting this, as this saved a hell lot of time & nuisance, for me...

all in anticipation of saving ones phone from rooting>deleting>installing all apps> and have pressure situation of whether all this will work or not

by just getting back to date from 10-12-2015 to 07-12-2015, in my case to be precise... VOILAA!!! everything back to normal ~~~ and here i am sharing my facts to help all those who are facing this ridiculous problem.

p.s. had been searching throughout the net for the solutionand found some interesting details... would love to share for others (if they can be of any help) ... factory formating/ soft or hard resetting wont work, so as the phone rebooting will also be noteffective ... setting back clock (manuallly) worked like a charm for me (my mobile lenovo Vibe X, carrier Vodafone) ... this problem arose, in my case, when i updated certain apps 5or6 OTA on Google Play Store (mainly Google inbuilt ones) ~~~ for others sufferers as i came to read through their posts >>> when they updated their handsets (for any updates... irrespective of any app) their wifi settings got disturbed causing the wifi to lock while initialising, not allowing the user to switch On or OFF, just displaying the scree n WIFI turning ON/Scanning/Starting/Searching/etc. ... a common solution suggested by many (which even i was going to try ~ if above hadn't work) was

> solve it by deleting /data/misc/wifi/wpa_supplicant.conf. It will reset all your saved networks. have your phone rooted and delete the file through a root explorer or you can remove it via ADB (adb shell rm -r /data/misc/wifi/wpa_supplicant.conf. I'm not sure).

You may backup it before, then open with a text reader to see your saved passwords.<<<

on many forums, this was the common solution accepted as the only chance to get rid of the problem.

Hope my this post helps you all,

regards

0

I have a samsung Galaxy S5 I seemed to have fixed mine by going to settings, Internet, Advanced, Manage website data. Then clearing out all the saved webpages which i dont know why it saved in the first place This is the first its happened to me But after a few times of flicking the wifi it seems to be working fully now Hope this helps someone else <3

0

As suggested above, I cleared out the saved webpages in the 'internet' app and changed the date in 'time and date settings' to one week back. Restarted the phone and bingo! No more flashing wifi symbol on and off every couple of seconds! I had tried all the other stuff (restarting etc) apart from the rooting. This worked on a Galaxy Note 4, no rooting, no safe mode starts.I hope it works for others. I was sure this problem was draining the battery more than usual too? Thanks to everyone with all the suggestions above, especially 'aebbee'

0

I've got a Samsung S5 and had the same issue which severely drained my battery! None of the above worked for me. But I fixed it.

In the location settings it gives you the option to use Wifi or Bluetooth to increase accuracy - turn this off and voila.. : )

Hope this helps someone.

protected by Community Feb 21 '17 at 4:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.