I need to root my huawei mediapad s7-301u android tablet. Currently it is running android 4.0.3. My development PC is on 32-bit Ubuntu 12.04 LTS. I tried so many sites about rooting this tablet but getting so many issues here. I am explaining the issues below I faced while rooting.

Currently there is no google-play,CWM-recovery in my tablet so please consider this situation also when answering.

  1. So I downloaded android-sdk on my PC and got the adb and fastboot.
  2. then I downloaded a zip file and put it on my tablet and tried to reboot into recovery but I can't see anything like "install zip from sdcard". Only I can see 4 menu items reboot fastboot,reboot,recovery and power off.
  3. I tried the recovery one when I do that one android logo with some setting icon animation appears in green and the tablet goes to normal boot process and starts normally.
  4. When I press the power button and volume down button also nothing happens at boot time.
  5. Then I downloaded boot.img to flash it using fastboot. But here also fail. The fastboot lists my devices with command "fastboot devices" but when i try to flash, it stucks at "waiting for devices".

Now feel confused and messed up with tablet for rooting. Can anybody please guide me step by step process to check and root this tablet.

I will be so much grateful to get the answer.

  • I've just added a link to your question from our rooting index. Though that doesn't make your question answered, you still might want to check that page's "generic section", where different rooting methods are listed. Maybe there's one amongst them which works for your device (e.g. "root many", which is supposed to work with many 4.0/4.1 devices). – Izzy Sep 30 '13 at 6:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.