2

I have been trying and failing to connect my phone (Samsung GT-I8150, running CM10.2) to my Lenovo T420 laptop via Windows 7's "hostednetwork" facility.

The hostednetwork's SSID is visible in my phone, but after I fill in the password, it goes "Connecting" for several seconds, then back to "Saved". No error, no nothing.

I know hostednetwork works because I borrowed a colleague's phone, and his phone has no problem Connecting-Authenticating-Obtaining_IP.

Interestingly, I have no problems connecting my phone to a wifi router in a cafe, or in my home.

What could possibly be the problem between my phone and Windows 7's hostednetwork service?

.

Edit: To make things clear:

  • hostednetwork is Windows 7 facility to turn a laptop's wifi into an Access Point (Infrastructure mode)
  • My colleague's phone is an Alcatel D662 (running stock Android GB)
4
  • Please edit your question and clarify: is "hostednetwork" using infrastructure mode, or ad-hoc? What is "a colleague's phone" (I never heard of that brand ;) Hint: Android does not support ad-hoc natively.
    – Izzy
    Sep 30, 2013 at 13:10
  • Thanks, pepoluan! That rules out a) ad-hoc as possible source, and b) makes clear that Android as-such is not the issue here. One more thing you could check: What channel is that hostednetwork using? Depending on regulations, some channels are "out-of-band" by definition in certain regions, so your w7 might use a channel your Android device thinks is "illegal". If ch > 11, this becomes very likely, so make sure to use a channel <= 11.
    – Izzy
    Oct 1, 2013 at 7:17
  • Well, by default, activating hostednetwork on Windows 7 will give it Channel 11. Perhaps wpa_supplicant on CM10.2 is buggy? (I'm grasping at straws here... can't bear seeing my friend using my hotspot happily while I can't even connect)
    – pepoluan
    Oct 1, 2013 at 13:32
  • Have you tried a different channel (one between 1 and 9)? If that doesn't solve the issue, we can at least rule out this as the culprit.
    – Izzy
    Oct 1, 2013 at 14:57

2 Answers 2

1

Well, after tearing my hair out and feeling my hair became lighter, I gave up. But then, the wifi of the laptop became even flakier: It can no longer connect to the Office WiFi.

So, I did some drastic measures:

  1. Uninstall all ThinkPad utilities that manage the wifi

  2. Uninstall the wifi drivers

  3. Reboot

  4. Reinstall just the wifi drivers

Afterwards, I can connect to the office wifi... and hostednetwork works! Go figure :-/

0

On my W540 running Windows 8.1, disabling the "Lenovo Settings Mobile Hotspot Service" fixes the issue.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .