6

I just got a new 2012 Nexus 7 16 GB Wifi tablet today & setup it up. It is originally running 4.2.1. In a few minutes, I got the message that System update downloaded (4.3 Jelly Bean) & that I should touch to install it. Can I make the notification about the system update downloaded disappear? Unlike other notifications, this doesn't seem to go off when I try to slide it to the right.

Reason: There are various reports that screws up your Wifi - and my Nexus 7 is Wifi only (no 3G). I don't want to risk to install this by accident.

Update: I think another new update arrived and was downloaded (probably KitKat 4.4.3). And the notification showed up and didn't disappear even if Show Notifications was unchecked in Google Services Framework. Had to this uncheck 'Show Notifications' in 'Google Play Services' to make the notification disappear.

  • See if there are Wifi issues and you're waiting for them to be resolved, they would only be solved in a subsequent update and not the one you have waiting to be installed. – Jasjeev Singh Oct 1 '13 at 10:07
  • @JasjeevSingh Sure. But may be the next update will depend on the previous update being installed - i.e. it may be an incremental update rather than an absolute update. – user93353 Oct 1 '13 at 10:44
  • Probably won't be. You would know by the download size. – Jasjeev Singh Oct 2 '13 at 6:45
  • @JasjeevSingh you are missing the point. – user93353 Oct 2 '13 at 6:50
  • There was a fix for this AFAIK rolled out soon after the first 4.3 ROM for the Nexus devices. You should be fine, but read up on the LATEST ROM. You don't need to install if I you don't want. If a patch comes out, and not a full install you can get the stock ROM online and apply the patch, resolving the issues mentioned in the comments! – RossC Oct 4 '13 at 15:02
4
+50

Try disabling the notification then restart your tablet and see if it reappears:

Go to Settings > Application Manager > All > Google Services Framework and then uncheck "Show notifications".

Are you rooted? If so, and if disabling the notification doesn't work, try freezing or uninstalling the update apk:

Use Root Explorer or ES Explorer and go to phone memory system/app/ and delete or rename UpdateCenter.apk. Alternatively, you could freeze this application in Titanium backup application.

You could also try modifying your build.prop file to trick the tablet into thinking it's already updated (root required). This was also mentioned in an answer to a previous question.

To prevent the update notification, you will probably just have to change the build.prop values. So, change:

ro.build.description=voles-user 2.2.2 FRG83G 91102 release keys to

ro.build.description=voles-user 2.2.3 FRK76 185902 release keys

and

ro.build.fingerprint=verizon/voles/sholes/sholes:2.2.2/FRG83G/91102:user/release-keys to

ro.build.fingerprint=verizon/voles/sholes/sholes:2.2.3/FRK76/185902:user/release-keys

Note that this quote is referring to old software versions and that the ro.build.description and ro.build.fingerprint lines will need to look different for you than those quoted. Check out this answer for more information on making such a change.

For me and my 2012 N7 I just lived with the notification until I couldn't stand it any more, then I just upgraded anyway.

  • 1
    I am not rooted and I don't have a "Settings > Application Manager" item. Inside settings, there is Apps -> Running -> All -> Google Services Framework. I unchecked "Show Notifications" there. And the notification disappeared immediately. Didn't have to reboot. – user93353 Oct 11 '13 at 3:49
  • 1
    Neither the answer nor user93353's comment were quite correct for me. I had to disable notifications for "Google Play services" rather than "Google Services Framework" (which didn't work). This immediately removed the notification, but it may have side effects that I'm not anticipating. – abeboparebop Jan 5 '16 at 13:46
1

[EDIT]: This answer has been composed before the questioner stated that the fw update might break the wifi.

Why not just update it and be done if you want the notification to go away?

  • It's incremental (small download size)
  • It won't take long (installation is quick and needs only a reboot)
  • And gives you the benefit of bug fixes and enhancements.

Google has probably an intention that it's consumer base runs the latest firmware release. Hence the notification is not discardable and is there to remind you to update.

  • Google knows what's best for you... don't fight it, you're the one who's broken, let nice Google fix you... – gbjbaanb Jan 23 '14 at 9:00
0

These update notifications are a pain, and apparently they change the way they do them often, because lots of the information out there is no good. For example, the APK mentioned in one of the answers doesn't exist on my phone.

Disabling notifications for entire sets of services can be a nuisance - e.g. you lose all Gmail notifications, too.

I found various tips online:

  1. Long-pressing on the notification will open up a submenu with "App info" on it. You can click on that and find out who is the notification's owner.
  2. Then get DisableService and browse to that app. In my case, to get rid of the 4.4.2 update, I went to System Apps then Google Play Services (also hinted by the update on this question). You then will see a huge list which is not in alphabetical order, so look carefully. I found SystemUpdateService. Unchecked that, rebooted, and it's gone.

On reboot an app was automatically updated and I saw all the notifications for that. So this is a pretty clean solution (for this version, anyway).

0

I figured out how to fix the problem:

Phone: Nexus 4 running 4.4.2 - Accidentally downloaded 4.3 - Rooted

  1. Download System Tuner, Free from google play (https://play.google.com/store/apps/details?id=ccc71.pmw&hl=en)
  2. Open App
  3. Click Startups
  4. Navigate to Google Play Services - If you do not see this in the list, press add in the bottom right hand quarter and navigate to it
  5. press and hold over Google Play Services
  6. Press Open
  7. Press Details
  8. Press Activities
  9. Navigate to update.SystemUpdateActivity and uncheck it
  10. restart phone

This did the trick for me. I am unsure whether this also removes other notifications from google, but it certainly got rid of the annoying "system update downloaded" notification.

  • A link to the app you're recommending would be useful. – Dan Hulme Oct 8 '14 at 9:52
0

I found a simpler solution. When the notification poped, i held pressed down the system update notification, whichs opened a sub-menu. Went to "app info", which led me to app "Google Play services." Unchecked "Show notifications" and worked like a charm.

  • It seems odd that the OTA notification would be through Google Play ... surely this may prevent other, wanted notices to? – Matthew Read May 3 '15 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.