When I'm at work, I usually have a headset on my head and I am listening to music. My phone is always on vibrate to respect co-workers. However, I don't keep the phone in my pocket because of its size, so I don't feel it vibrating. I miss a lot of calls.

I was wondering if it's possible to forward "phone is ringing" notifications to the PC, ideally via a Bluetooth connection. I would not mind installing a 3rd-party app on the phone or software on the PC.


Currently Android doesn't have such functionality built-in.

However, there are 3rd-party apps that can do what you ask. Desktop Notifications is one such app. It requires installation of the app on the phone, as well as a browser plugin on your PC (Chrome and Firefox are currently supported.) Once both pieces are installed and configured, any notifications (including incoming calls) will pop up on your desktop. The only limitation is that this is done via data connection, not Bluetooth, so both your phone and your PC must be connected to the Internet.

On your desktop you may want to enable background apps to run when Chrome is closed to ensure you continue to receive notifications. This option can be found in Chrome advanced settings -> "Continue running background apps when Google Chrome is closed."

  • Thank you, I just tried. While the test notification, SMS and even emails notification seem to work, an incoming phone call does not seem to trigger any notification. But I will look into that and see if there is a setting somewhere. – Pierre-Alain Vigeant Oct 2 '13 at 18:37
  • The incoming call functionality worked for me. It did take close to 5 seconds for it to appear though. From the app's reviews it seems that response time (between notification arriving on the phone and showing up on the computer) is something that developers are working on improving. – Chahk Oct 2 '13 at 18:46
  • Press the Menu key while in the app and go to Settings. The "Phone" app should be selected in the "Allowed" list in order to send notifications to the PC. Also, there's a useful setting to send notifications while on WiFi only. – Chahk Oct 2 '13 at 18:47
  • Weird, the phone app is checked and even say that there was 37 notifications. Clearly something is wrong. Maybe I should restart the phone. – Pierre-Alain Vigeant Oct 2 '13 at 19:11
  • 1
    @nwaltham I am using Desktop Notification. Sadly, you only get the notification after the phone call. – Pierre-Alain Vigeant Jun 27 '14 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.