I want to disable the soft keyboard on asus tf300t permanently. I have read a lot of post on stackoverflow that allow you to block the soft keyboard but all of them explain how to do them in a specific app. I have root access to the device. its running cyanogenmod 10.0.0 on it. it has a dock keyboard. I could not find the .apk fie in /system/app for the soft keyboard that I could remove. does someone know how to remove the soft keyboard ?

thank you

  • I remember having read about a method to disable a given IME (Input Method) via ADB, but cannot find it currently (see also: Flaw in adb shell ime list -a? for a starter). But this hint might give you an idea what to look out for, I hope... – Izzy Oct 3 '13 at 16:18
  • I found a file /system/app/LatinIME.apk This file is responsible for the soft keyboard. I tried to change the name of the file from the terminal but it wont allow me to do so. kept giving an error "Read only file" So I installed root explorer. in root explorer there is a tab top right that enables you to mount R/W to rename that file. then I went back to the terminal and renamed the file so the system does not recognize the file. this blocks the soft keyboard from poping up on anywhere in the cyanogenmod. – tanzeelrana Oct 3 '13 at 18:32
  • Yeah, but that's not the clean way to do it. It had been cleaner to disable the app (than to remove/rename it), which could be done with e.g. pm (the Android package manager) via adb shell. But whatever you like, as long as it solves your issue :) – Izzy Oct 3 '13 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.