1

I've just acquired Nexus 7 (2013) and can't connect it to my PCs. All drivers I have (one from Android SDK, as I'm a developer, and the second from the Android site here, named as latest_usb_driver_windows.zip btw) do not install either under Windows 7, or Windows XP. PC discovers new device as "Nexus 7", but wizard says "could not find the software on your computer" when I specify folder with drivers.

After some unsuccessful trials, I decided to disable MTP and mass storage modes on the Nexus, just to eliminate these parts of driver - in fact I need only debugging via USB. I enabled the debugging via USB at very beginning, and it shows up in Android's notification bar, but the device does not show up in adb/Eclipse.

So I switched MTP and mass storage OFF via notification area. This did not help to attach the new device. But now I can't enable either MTP or storage mode back. They are missing in notifications, and they are missing in Settings -> Wireless & Networks -> More, where they are supposed to be.

So the question number 1: how one can switch MTP and storage mode ON in Android 4.3, specifically on Nexus 7 (2013), other way than via notifications? I saw similar question on the Internet, and the only answer was to reboot the device - in some cases (from time to time!) this worked for someone. I restarted Nexus, but still nothing USB-related shows in settings.

Also I'd appreciate any clues on how to connect Nexus 7 (2013) to Windows PC? I should mention, that I have Nexus 7 of the first version, and I'm able to debug apps using it, that this first Nexus is connected to the same PC successfully. This brings another problem, because I do not want to lose connectivity with the first device by complete removal of drivers, because I have no guarantee that after this the first device will not become lost in the same manner as the second.

Thanks in advance.

  • FWIW: The MTP setting should be in Settings > Storage > (overflow menu) > USB computer connection, not in Wireless & Networks. On the ADB issue: do you see any entries in Device Manager on the computer when you plug in the N7 with debugging enabled? – eldarerathis Oct 3 '13 at 21:30
  • @eldarerathis, thank you, I found the MTP/storage menu. Yes, I see "Nexus 7" device in the Device Manager when I plug it, and wizard starts. – Stan Oct 3 '13 at 21:41
  • @eldarerathis, strangely, I managed to update the driver from the same location which has failed so many times before this (did you help metally somehow? ;-) ). You may post your comment as the answer. – Stan Oct 3 '13 at 21:49
  • @Stan Since you've solved your problem, could you add your own answer and then "accept" it? That way, other visitors can see the problem is solved. – Dan Hulme Dec 1 '13 at 15:50
  • @DanHulme, my solution was just to keep trying again and again until it works I have no idea why. Do you think this is eligible for a real answer? – Stan Dec 2 '13 at 10:31
2

Had similar problem with Google Nexus7 (2012).

To solve it I passed next steps:

  • Uninstalled incorrect Nexus USB drivers.
    1) Previously, I installed windows default MTP driver to have ability to connect the device. It was a bad solution, because it made a problem for me to install new drivers.
    Each time I tried to install latest_usb_driver_windows.zip from developer.android.com, Windows told me:

    “The best driver software for your device is already installed”

    So I disconnected all USB devices, and in order to remove all previously installed USB drivers I used freeware tool DriveCleanup.
    It was a bit unusual to run some tool, which perform some unknown system-related actions, but at the end of the day, it removed all USB-drive related stuff from Windows and didn't harm a system.

  • In order to install proper USB drivers for my Nexus 7 on Windows 7 performed next:

    1. Enabled debugging options on Nexus (Go to Settings > About tabled and tap 7 times on "Build number" field);
    2. Run "Settings -> Developer Options -> Revoke USB debugging authorizations", in order to start next negotiating between tablet and PC from scratch.
    3. Enabled "Settings -> Developer Options -> USB debugging" to have ability to connect to the device by adb.
    4. Connected device to PC. (Some informaition in the internet points, that in case of problems drivers installation, it's better to use USB 2.0, but I have only USB 3.0 on my PC)
    5. Run "Device Manager" Windows tool. "Start -> Run -> mmc devmgmt.msc" or "Control Panel -> Device Manager"
    6. Found Nexus Device, press right mouse button "Update Drivers -> Manual -> Browse", pointed to the latest usb drivers from google (In my case, they were downloaded by Android SDK manager: C:\Program Files (x86)\Android\android-sdk\extras\google\usb_driver). And press OK.
    7. In most of cases, previous 6 steps should be enough to install drivers, but each time I received next error:

    "The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

  • So in order to make USB drivers fit my device, I performed next steps:

    1. Run "Device Manager" Windows tool. "Start -> Run -> mmc devmgmt.msc" or "Control Panel -> Device Manager".
    2. Found Nexus Device, press right mouse button "Properties -> Details" chose "Hardware IDs" from the dropdown, right mouse button on ID values "Select All -> Copy"
      In my case it was:

      USB\VID_18D1&PID_4E42&REV_9999&MI_01&MI_01
      USB\VID_18D1&PID_4E42&MI_01&MI_01

    3. Opened usb_driver\android_winusb.inf file from latest usb driver directory by text editor, found [Google.NTamd64] section (there is also [Google.NTx86] section for 32 bit PCs). In amd64 section I found a ;Google Nexus 7 section. It looked like:

      ;Google Nexus 7 %SingleBootLoaderInterface% = USB_Install, USB\VID_18D1&PID_4E40 %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42&MI_01 %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E44&MI_01

    4. Basing on IDs, taken from my hardware:
      USB\VID_18D1&PID_4E42&REV_9999&MI_01&MI_01
      USB\VID_18D1&PID_4E42&MI_01&MI_01
      I added to the Nexus section next lines, using as last parameter of CompositeAdbInterface device ID with removed revision and all the text after it:

      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42&MI_01&MI_0

    5. Nexus section of android_winusb.inf file started to appear next way:

      ;Google Nexus 7
      %SingleBootLoaderInterface% = USB_Install, USB\VID_18D1&PID_4E40
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42&MI_01
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E42&MI_01&MI_01
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_4E44&MI_01

      After this modification, Updating of USB Driver from Device Manager finished successfully. Maybe It is not the properest way to fix this problem, but it was first working solution, so I stopped further investigations.

0

Seems like you need to turn either camera or storage in Settings > Storage > (overflow menu) > USB computer connection (on your Nexus7 2013) to install the adb driver

0

I'm posting the solution (as @DanHulme asked me) despite the fact that it's trivial.

If you already use latest drivers and have no option to reinstall a part or entire system, the only way is to keep trying with what you have again and again.

I don't know what exactly happened, but after a day of trials (plugging the new device and removing it, pointing the system to the drivers in this way or another) it was finally connected.

As for the other side-question about MTP, it was actually answered by @eldarerathis in comments: MTP mode can be enabled/disabled in Settings > Storage > (overflow menu) > USB computer connection.

0

When changing mode and looking at device manager:

  • MTP: i see only the "Nexus 7" device under "Portable Devices", not updatable

  • PTP: i see "Nexus 7" under both "Portable Devices" and "Other devices"

  • none: i see only "unknown device" under "Other devices", not updatable

So, to fully install drivers, with adb interface, i had to put it first into PTP mode (+debubbing mode). Then update the drivers of the nexus 7 device under "other devices" manually with the google drivers.

Now put the tablet in MTP mode and update the nexus 7 driver under "portable devices". choose "let me pick...", then "composite..".

The "Android Composite ADB Interface" now appear under "Android Device".

et voila..

0

I ended up doing a variation of this...the problem I had was the portable/other devices issue. The MTP portion of the driver seemed to be working so I wasn't getting a warning in Device Manager...ergo, I didn't even know that existed until you mentioned it in this post. Updated from the "Portable Devices" bit and it worked right off.

0

This Worked for me. I have uninstalled the old driver from Device manager.. While uninstalling driver choose "Delete the driver software for this device" option. and reconnect your android device.

( Control Panel -> Device Manager -> Right click "Nexus ADB interface" -> Properties -> Driver tab -> uninstall -> Check "Delete the driver software for this device" -> ok )

enter image description here

0

windows may have the adb drivers installed. this will be loaded in place of the mtp drivers. uninstall the adb drivers (do a driver delete if the option comes up), and re-plug-in your nexus 7 with the drivers uninstalled.

it should load the mtp drivers by default, but if not, you can try and do an "update driver..." to force-load the mtp drivers. go to device manager -> acer device -> acer adb drivers -> properties -> driver -> update driver... -> browse my computer -> let me pick from a list -> mtp usb device.

the same device can go into 3 different modes, so windows may be confused by this (probably more accurately acer's drivers' fault).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.