When running adb devices in cmd, it says that my phone is unauthorized. It appears that it has something to do with the RSA fingerprint prompt. I don't remember ever getting such a prompt. Yes, I am running in PTP mode and debugging is enabled. I tried, after looking around on internet for multiple hours:

  • Enabling/disabling debugging mode repeatedly
  • Uninstalling and reinstalling my drivers for my phone or ADB
  • adb-killserver and adb-startserver
  • Restarting my phone and unplugging/replugging in multiple ways

I did notice that in my (user)/.android/ folder, I don't have a file called adbkey.pub (which is apparently the file that's supposed to have my key). Anyway, I don't think I've ever received the prompt about RSA fingerprint and I can't make it appear in any way.

Do you guys have any idea what I could do at this point. I tried about everything on these forums and around on the Internet but maybe there is something else I could do. Should I reset my phone to factory settings at this point to make the prompt appear again?


There are two possibilities:

  1. Update your pre 4.2.x SDK to the latest version that includes RSA auth.

  2. If I'm right to assume you're running Linux (user/.android/). In case of Ubuntu/Debian: The 'android-tools-adb' package provides the adb binary which is preferred to that of the SDK. If it is installed, it must be recent (>4.2), because RSA authentication isn't integrated in earlier versions. You can manually download that of Roaring and install it on 12.xx, i have tested this already and it worked. Or just use that from the SDK. Be sure to kill the old adb server instance after upgrading/fixing the version.

  • My SDK is already up to date (it says 22.2.1 or API 18) and no I'm not using Linux unfortunately. Do you think I should root and go in my data folder somewhere on my phone and delete the key file? Is it really necessary or is there something else I can do? Oct 5 '13 at 15:19
  • 1
    Try revoking USB Debugging Authorisation in developer options. I think that's virtually the same as deleting the key file.
    – Rhaegar
    Nov 14 '15 at 13:49

Couple of things could help:

  • actually, sometimes happens that you cable, used for connection is getting broken, try with another one
  • when connected, in notification shade select USB for charging and change it to either MTP or Storage

USB for charging enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.