I'm attempting to run an app on the LG G2 (Verizon) using Eclipse on a Mac. The phone, however, is not recognized by the computer. I enabled debugging but it doesn't appear when I do adb devices. Additionally, I never receive the debugging notification when I put the phone in debugging mode. I think it's the phone since I've ran other devices on the mac with no problems.

Any suggestions on why the debugging mode is not being enabled?

  • Have you installed drivers for your phone? – geffchang Oct 10 '13 at 2:02
  • It's a mac; drivers are not needed. I placed the connection to internet when connected to USB. For some reason, only that USB settings enables debug mode – ono Oct 10 '13 at 2:41
  • Having the same problem. Tried multiple cables, including the one that came with the phone and that works for charging in fast mode. – pjb3 Oct 31 '13 at 16:46
  • Could this be the same problem as android.stackexchange.com/q/53554/12442 ? – Dan Hulme Nov 9 '13 at 10:12

I found the solution: Assuming you have debugging mode enabled, you have to change the USB settings to Internet Connection: Modem or ethernet. Keeping it on Charge Phone, Media Sync, or Camera does not enable debugging.

  • Actually you need to run in tethering only once per computer - in order to get the prompt for allowing the connection from the computer. After you give permanent rights of access you can develop in charging mode too. – Boris Strandjev Nov 22 '14 at 13:15
  • 2
    Only way I got USB debugging to work was to select Send images (PTP). Charge tablet and Media sync(MPT) did not work. – user129894 Dec 30 '14 at 3:46
  • I follow @ono answer and also found the solution. I had to follow three steps: 1) In settings/general/about phone/common/software info, click 7 times in build number; 2) In general/developer options, turn on usb debugging; 3) In network/tethering&networks, turn on usb tethering. – msampaio Aug 13 '15 at 22:03
  • I had this same problem in an LG Leon. You have to pick "PTP" as @user129894 said, nothing else worked! – scorpiodawg Mar 14 '16 at 21:04

The user44860 answer is almost correct. Goto Settings, About Phone, Software Information:

Click Build Number 7 times. You should see a message saying that now you're a developer.

So, you can go back and enabe USB Debugging in the Development Settings.

Maybe you've to detach the usb cable, enable the debug and re-plug the usb cable.


on the G2 goto Settings: About Phone: Software Information: Click Build Number 5 times. Go back and choose Development Settings Enable USB Debugging


Try another usb2 cable. I had the same issues with the S2 after a while it gives me Unknown Device, even if before was known. Try another cable and see if is being recognized. As well it has to be on MTP ( media device ) and not PTP (camera).

Also you could try another thing: while your phone is connected disable debugging mode and enable it back. Also could try restarting your adb.

  • disable / enable debugging mode helps me. Otherwise the 'USB debugging' mode was disabled all the time. – tsenapathy Apr 1 '16 at 16:36

protected by Community Dec 7 '13 at 13:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.