12

Hi I have got Samsung Galaxy S4 Active.

I have downloaded Samsung's high quality British English TTS engine and set it as "Preferred TTS engine" From Settings -> MyDevice -> Accessibility -> Text-to-speech options -> Samsung text-to-speech engine -> Languages

However when I use Google's Navigation app, it still uses Google's TTS engine.

Furthermore I actually disabled google's TTS engine so it is not present at TTS options, the problem still persists!

The only thing that I have discovered is if I change preferred language from English UK to English US, then TTS engine changes in Google's Navigation App from Google's English UK to English US!

I thought the problem is at Samsung's TTS Engine. So I downloaded Ivona TTS Engine and tried same languages and experiencing same problems with that too.

Is there a solution for this stubborn Google's Navigation app's voice?

  • On my Samsung Galaxy S3 with Android 4.3, Google Maps uses low quality female US voice no matter what TTS setting I specify. Downloaded and activated UK high quality HD female Google and Samsung TTS packs, but Maps always uses low quality female US. – SabreWolfy May 18 '14 at 11:54
  • Google's navigation voice has always been some google related voice. The only option might be is if you download a high quality version of one of the google voices. I personally have never been able to change the voice used by Maps/Navigation. – The3rdIcon Sep 23 '15 at 18:39
  • Google Maps always uses the same voice, regardless of TTS settings. It's totally separate, and you can't change it. – owlswipe Jun 6 '16 at 22:30
1

If all you want is a British voice, then you don't have to downgrade from Google Maps version 9.32.1, there's another way:

SETTINGS > LANGUAGE AND INPUT > LANGUAGE > English (United Kingdom)

This changes the language settings for the entire phone, but I haven't noticed any major difference, but I do love having a British girl's voice give me driving directions and the audio quality is almost as good as the Ivona British voice.

I used to use Ivona but prefer this method now because it doesn't require installing an extra app.

Try it out and see if this helps! It's easy to go back if you don't like it. Just change it back to English (United States).

If it doesn't work, then please make sure that:

TEXT-TO-SPEECH OPTIONS > Google Text-to-speech engine

is selected. And while you're in that screen, download the speech data for that language:

GOOGLE TEXT-TO-SPEECH ENGINE "GEAR ICON" > INSTALL VOICE DATA > English (United Kingdom)

What's also cool about this method is that your Google Now girl now has a British accent as well!

Hope this helps! :)

0

In the Google Play Store, uncheck the option to Auto update maps.

Uninstall Maps (or updates to maps if it is a system app).

Install (or update) to Maps version 9.1.2

Disable Google TTS engine.

Reboot phone.

protected by Community Jan 26 '14 at 15:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.