I have an HTC Desire S, which my cousin bought for me from China.

Android version: 4.0.4; HTC Sense version: 3.6; Software number: 1.0.0.S510e

The MicroSD card no longer works. Whenever I reinsert it, I get the message, after a few seconds, "SD card safe to remove". I've tried reformatting it and have run fsck on it.

I think the card used to mount read-only before, as it used to unmount whenever I took a picture; this started happening after the most recent update. I kept trying to take pictures and reinserting the card would fix it but it seems now it won't mount.

How can I fix the MicroSD card so it'll mount?

3 Answers 3


I'm assuming you mean MicroSD, not SD. Sounds like the card is broken. You could try formatting it as ext3 or FAT and see if either work. Also, see if it works on a PC (you can get a MicroSD/USB adapter for next to nothing).

  • Is it possible to use a MircoSD card with ext3 with android?
    – thedoctar
    Commented Oct 18, 2013 at 19:01
  • 1
    Actually I formatted it as ext3, and when I put it in the mobile, it said the filesystem was incompatible and reformatted it correctly. It works now!
    – thedoctar
    Commented Oct 26, 2013 at 0:57

Same thing happening to me. After updating my Galaxy Grand to 4.2.2 i can no longer use the phone to format ANY MicroSD cards... Very strange. I need to format to Fat32 on PC and then it will work. Even if i format to extFAT on PC the phone will reject it.

As an experiment, I deleted the partition on the MicroSD card with my PC. I then placed it into my phone. It prompted me that the card was unformated. When i formatted it with the phone all i got was "SD Card safe to remove". I removed the card from the phone and checked it with my PC. The phone did format the partition, but it was set as "Other" type..

Don't know what to make of this...


I had that problem with Dual USB flash, for PC and Mobile, it is 64gb so I couldn't format is with FAT32. I did the exFAT and NTFS but same thing happened. But then I found the solution on SanDisc website, it says that some mobile phones don't recognize exFAT, but FAT32 only.

They provided few third party softwares for FAT32 formating of 64gb:

HP USB Disk Format Tool , 2Tware Fat32Format , and miniAide Fat32 Formatter

I did it with second one and it works! My phone finally can recognize the USB flash.

I googled it few hours and except this solution didn't find absolutely nothing that works...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .